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About This Book

Subject This book describes the PowerBuilder development environment. It
shows you how to use the variety of tools that PowerBuilder provides to
build applications.

Audience This book is for anyone who will be building applications with
PowerBuilder. It assumes that:

¢ You are familiar with the user interface guidelines for the
computing platform you will be developing and deploying your
applications on. If not, consult a book that covers user-interface
conventions.

¢ You have a basic familiarity with SQL. If not, consult a book that
describes SQL statements.
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PART 1 The PowerBuilder
Environment

This part describes the basics of using PowerBuilder
and how to set up and maintain an application.






CHAPTER 1 Working with PowerBuilder

About this chapter This chapter describes the basics of working with PowerBuilder and its
painters.

Contents Topic Page
What is PowerBuilder? 4
The PowerBuilder environment 7
Painter summary 10
Using online Help 12
Using popup menus 14
Using property sheets 16
Using toolbars 18
Using the file editor 27
Changing fonts 31
Defining colors 32
Managing the initialization file 33
Building an application 37
Starting PowerBuilder from the command line 39

Before you begin If you are new to PowerBuilder, you should first do the tutorial in Getting

Started. The tutorial guides you through the process of building a
PowerBuilder application.



What is PowerBuilder?

What is PowerBuilder?

What'sin a
PowerBuilder
application?

Cross-platform
development

Internet development

PowerBuilder is a graphical application development environment. Using
PowerBuilder, you can easily develop powerful graphical applications that
access server databases. PowerBuilder provides all the tools you need to build
industrial-strength applications, such as order entry, accounting, and
manufacturing systems.

PowerBuilder applications consist of windows that contain controls that users
interact with. You can use all the standard controls—such as buttons,
checkboxes, dropdown listboxes, and edit controls—as well as special
PowerBuilder controls that make your applications easy to develop and easy to
use.

PowerBuilder supports cross-platform development and deployment. For
example, you can develop an application using PowerBuilder under Windows
(either Windows 95 or Windows NT) and deploy the very same application—
without changes—on a Windows 3.1, Macintosh, or UNIX machine. You can
even have a cross-platform team of developers, some using Windows and some
using the Macintosh, developing the same application at the same time. They
can freely share PowerBuilder objects used in the application, because the
objects are the same across the different computing platforms that
PowerBuilder supports.

Most of the figures in this book show PowerBuilder running on Windows 95,
but the PowerBuilder graphical user interface looks and works much the same
on all platforms.

FOR INFO  For more information about cross-platform development using
PowerBuilder, see Application Techniques.

PowerBuilder includes a number of tools that let you build web-based
applications and extend your existing applications to the Internet.

FOR INFO For more information about Internet development using
PowerBuilder, see Building Internet Applications with PowerBuilder.

About the painters

You build the components of your application using painters, which provide
an assortment of tools for building objects. PowerBuilder provides a painter for
each type of object you build.
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For example, you build a window in the Window painter. There you define the
properties of the window and add controls, such as buttons and edit controls.

About events and scripts

About functions

PowerBuilder applications are event-driven: users control the flow of the
application by the actions they take. When a user clicks a button, chooses an
item from a menu, or enters data into a textbox, an event is triggered. You write
scripts that specify the processing that should happen when the event is
triggered.

For example, buttons have a Clicked event. You write a script for a button's
Clicked event that specifies what happens when the user clicks the button.
Similarly, edit controls have a Modified event, which is triggered each time the
user changes a value in the box.

You write scripts using PowerScript, the PowerBuilder language. Scripts
consist of PowerScript commands, functions, and statements that perform
processing in response to an event.

The script for a button's Clicked event might retrieve and display information
from the database; the script for an edit control's Modified event might evaluate
the data and perform processing based on the data.

Scripts can also trigger events. For example, the script for a button’s Clicked
event might open another window, which triggers the Open event in that
window.

PowerScript provides a rich assortment of built-in functions you use to act
upon the objects and controls in your application. There is a function to open a
window, a function to close a window, a function to enable a button, a function
to retrieve data, a function to update the database, and so on.

You can also build your own functions to define processing unique to your
application.
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About libraries

You save your objects, such as windows and menus, in PowerBuilder libraries
(PBL files). When you run your application, PowerBuilder retrieves the objects
from the library. PowerBuilder provides a Library painter for you to manage
your libraries.

Creating an executable

When you have completed your application, you create an executable version
to give to your users. PowerBuilder provides an easy way to package your
application for distribution.
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The PowerBuilder environment

When you start PowerBuilder, it opens in a window that contains a menu bar
and the PowerBar:

You use PowerBuilder painters to create the windows, menus, database tables,
and other objects you need in your application. You can open painters and
perform other tasks by clicking buttons in the PowerBar.

About the PowerBar

The PowerBar displays when you begin a PowerBuilder session. The
PowerBar is the main control point for building PowerBuilder applications.
From the PowerBar you can open a PowerBuilder painter, debug or run the
current application, or customize PowerBuilder to meet your needs.

Customizing the You can customize the PowerBar. For example, you can choose whether to

PowerBar display text in the buttons, move the PowerBar around, and add buttons for
operations you perform frequently.

FOR INFO  For more information, see "Using toolbars" on page 18.



The PowerBuilder environment

About PowerTips

By default, PowerBuilder displays a brief description of the button, called a
PowerTip, when you leave the mouse pointer over a button for a second or
two.

About the PowerPanel

Like the PowerBar, the PowerPanel enables you to open painters and tools and
perform other activities. It contains all the tools that are available throughout
PowerBuilder, including tools that are not in the default PowerBar.

0,
*

To use the PowerPanel:
1 Select File>PowerPanel from the menu bar.
The PowerPanel displays.

2 Click an item on the list to access a painter or tool and click OK.

Shortcut

To access a PowerPanel item quickly, type the first letter or two of the
item name. The PowerPanel jumps to that item immediately. For
example, to jump to the System Options item, type S.

About the The PowerPanel dropdown toolbar offers a quick way to access most

PowerPanel PowerPanel items. When PowerBuilder first opens, the two buttons at the left

dropdown toolbar of the PowerBar both open the Application painter. The button on the left has
a down arrow next to it. Click the arrow to display the PowerPanel dropdown
toolbar:
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Whenever you click a button in either the PowerBar or the PowerPanel
dropdown toolbar, that button replaces the leftmost button in the PowerBar.



Painter summary

Painter summary

The buttons in the PowerBar and PowerPanel represent each of the main
painters and tools frequently used in PowerBuilder:

10

Painter or tool

What you do

Application
painter

Specify information about your application, such as its name
and the PowerBuilder libraries in which the application's
objects will be saved

Project painter

Create your executable by specifying the components that go
into the application

Window painter

Build the windows that will be used in the application

User Object
painter

Build custom objects that you can save and use repeatedly in
windows

Menu painter

Build menus that the windows will use

Structure painter

Define structures (groups of variables) for use in your
application

Function painter

Build functions to perform processing specific to your
application

DataWindow
painter

Build intelligent objects called DataWindow objects that
present information from the database

Report painter

Build and preview reports (DataWindow objects without
update capability)

Run Report

Preview reports

Query painter

Graphically define and save SQL SELECT statements for
reuse with DataWindow objects and reports

Data Pipeline

Transfer data from one data source to another

painter

Configure Define a data source that uses ODBC

ODBC

Database Define and use named sets of parameters to connect to a
Profiles particular database

Table painter

Create database tables, alter existing tables, and define keys,
indexes, and relationships between tables

Database painter

Maintain databases, control user access to databases, and
manipulate data in databases
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Painter or tool

What you do

Database Perform database administration tasks, such as maintaining

Administration users and security

painter

Browser View information about system objects and objects in your
application, such as properties, events, functions, and global
variables, and copy, export, or print it

Library painter Create and maintain libraries of PowerBuilder objects

File Editor Edit text files such as source, resource, and initialization files

Run Run your current PowerBuilder application just as your users
would run it

Debug Set breakpoints and watch expressions, step through your

application, examine and change variables during execution,
and view the call stack and objects in memory

Run window

Run a single window in your application

System options

Set PowerBuilder preferences such as initialization path,
fonts, and profiling preferences

Help

Opening a painter or tool

Invoke the PowerBuilder online Help system to give you
quick answers to questions

There are several ways to open a painter or tool:

From here You can

PowerBar Click the button for the painter or tool
PowerPanel Select the painter or tool

PowerPanel Click the button for the painter or tool

dropdown toolbar

Library painter or

Double-click an object to open it and start the

Browser corresponding painter

File menu Select one of the last four objects you’ve worked on—
they are listed at the bottom of the File menu

Anywhere Use shortcut keys to open a painter or tool directly—

shortcut keys are listed in the PowerPanel

1
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Using online Help

PowerBuilder has online Help that provides both reference and task-oriented

How to access Help

Learning to use
online Help

Using the popup
menu

information.

You can get Help in any of these ways:

Approach

What it does

Use the Help menu on the menu bar

Displays the Help contents, the
Welcome to PowerBuilder window, or
Help for the current painter

Click the Help button on the
PowerPanel (you can add the Help
button to the PowerBar if you want to)

Displays the Help contents

Press Fl

Displays the Help contents

Press sHIFT+F1 in the PowerScript
painter or Function painter

Displays context-sensitive Help about
the object under the cursor

Select Help from the popup menu in
the Browser

Displays Help for the Browser or for
the selected object, control, or function

Click the Help button in a dialog box

Displays information about that dialog
box

To get information on using Help, press F1 anywhere within online Help.

PowerBuilder online Help provides a popup menu with shortcuts to features

available on the Help menu bar.

To display the popup menu in online Help, click the right mouse button on
Windows and UNIX, and press the OPTION key and click the mouse button on

Macintosh.

Linking to the online books

12

Some Help topics provide links you can click to go to the Powersoft Online
Books. These links are represented by a picture of a CD.

FOR INFO  For information about installing the Powersoft Online Books and
reading them from a CD or from a server, see the Installation Guide.



Chapter 1 Working with PowerBuilder

Online books on the
Macintosh

Online books on AIX
and HP-UX

R
0.0

FOR INFO  For information about searching and using the annotation
features in the Powersoft Online Books, see the Using the Powersoft Online
Books collection in the Powersoft Online Books.

Powersoft Online Books on the Macintosh are available through an external
folder only.

To view online books on the Macintosh:

1 Open the folder where you installed the Powersoft Online Books.

2 Open the Online Book folder.

3 Double-click the PowerBuilder Online Book alias.

Powersoft Online Books on AIX and HP-UX are not available from the online
Help.
To view online books on AIX or HP-UX:

¢ Double-click the PBBooks icon in the folder where you installed the
Powersoft Online Books.
or
Enter the following command in a shell:

pbbooks &

13
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Using popup menus

Example

Working with multiple
objects

14

PowerBuilder provides a context-sensitive popup menu that lists:

¢ Actions appropriate to the currently selected object or the current
position of the pointer

¢ Where appropriate, a Properties menu item for accessing the property
sheet associated with the current object or the current position of the
pointer

The popup menu is available almost everywhere in PowerBuilder.

For example, the following screen shows the popup menu for a column in a
report:

dw_func_caller

Self + % Self +
Routine Hits Self _%Self Called Called

name hits abs_selfpct_self abs

dw_func

To display a popup menu:

1  Select an object, or position the pointer on an object or in an open area
of the workspace.

2 Click the right mouse button.

On Macintosh
On the Macintosh, press the CONTROL key while you click the mouse.

The appropriate popup menu displays.

3 Click the menu option you want.

If you want to perform an action on multiple objects, you can select them (you
can use lasso selection to do this) and display the popup menu.
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When multiple objects are selected, you cannot use Properties from the popup
menu to change their characteristics. The Properties menu item only works on

single objects. You can use a painter’s StyleBar to change properties for
multiple objects.

FOR INFO  For more information about working with multiple objects, see
"Selecting objects in the DataWindow painter” on page 474.

15
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Using property sheets

Example

Property sheet
buttons

16

A property sheet is a tab dialog box you use to set properties associated with
an object, painter, or tool by making changes in one or more tabs in the dialog

box.

For example, for a column in a report, you can set several different kinds of

properties (general, font, position, pointer, edit style, display format, and

conditional expressions) by clicking appropriate tabs in the Column Object

property sheet:

ame of the department

Each property sheet has OK, Cancel, Apply, and Help buttons. The Apply

button is enabled when you make a change on one tab:

Use this button

To do this

OK Apply the properties you've set on all tabs and close the
property sheet

Cancel Close the window and apply no new changes

Apply Apply the properties you've set on all tabs immediately
without closing the property sheet

Help Get Help on setting properties for the tab that displays
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Displaying property

sheets

You can display property sheets in four ways (the first two are usually faster):

L4

By selecting Properties from the popup menu of an object, painter, or
tool

By double-clicking an object

By selecting Object>Properties or Edit>Properties from the menu bar
(depending on the painter you are working in)

By clicking the Properties button in the PainterBar

17
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Using toolbars

Toolbars provide buttons for the most common tasks in PowerBuilder. You can
move (dock) toolbars, customize them, and create your own.

Toolbar basics

PowerBuilder uses three toolbars: the PowerBar, PainterBar, and StyleBar:

This And (unless

toolbar Has buttons for hidden) displays

PowerBar Opening painters and tools Always

PainterBar Performing tasks in the current painter In each painter

StyleBar Changing the properties of text, such as In appropriate painters
font and alignment

Dropdown toolbars

To reduce the size of toolbars, some toolbar buttons have a down arrow on the
right that you can click to display a dropdown toolbar containing related
buttons.

For example, the down arrow next to the Text button in the DataWindow
painter displays the Objects dropdown toolbar, which has a button for each
object you can place on a DataWindow object:

18
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Default button replaced

The button you select from a dropdown toolbar replaces the default button
on the main toolbar. For example, if you select the Picture button from the
Objects dropdown toolbar, it replaces the Text button in the PainterBar.

Controlling the display of toolbars

)
*

You can control:

¢  Whether to display individual toolbars and where

¢ Whether to display text on the buttons

¢  Whether to display PowerTips

Choosing to display text and PowerTips affects all toolbars.

To control a toolbar using the popup menu:
1 Position the pointer on the toolbar and display the popup menu.
2 Click the items you want.

A checkmark means the item is currently selected.

To control a toolbar using the Toolbars dialog box:

1  Select Window>Toolbars from the menu bar. (If no painter is open,
select File>Toolbars from the menu bar.)

The Toolbars dialog box displays.

2 Click the toolbar you want to work with (the current toolbar is
highlighted) and the options you want.

PowerBuilder saves your toolbar preferences in the PowerBuilder initialization
file.

Moving toolbars using the mouse

0.0

*

You can use the mouse to move a toolbar.

To move a toolbar with the mouse:

1  Position the pointer on the grab bar at the left of the toolbar or on any
vertical line separating groups of buttons.
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2 Press and hold the left mouse button.
3 Drag the toolbar and drop it where you want it.

As you move, an outlined box shows how the toolbar will display when
you drop it. You can line it up along any frame edge or float it in the
middle of the frame.

Docking toolbars

When you first start PowerBuilder, all the toolbars display one above another
at the top left of the workspace. When you move a toolbar, you can dock
(position) it:

¢ At the top or bottom of the workspace, at any point from the left edge
to the right edge

¢ At the left or right of the workspace, at any point from the top edge to
the bottom edge

¢ To the left or right of, or above or below, another toolbar

Example These two toolbars are on separate docks:

You could customize the toolbars to reduce their size, then dock them side by
side:

MS Sans Serif

Customizing toolbars

You can customize toolbars with PowerBuilder buttons and with buttons that
invoke other applications, such as a clock or text processor.

Adding, moving, and deleting buttons

You can add, move, and delete buttons in any toolbar.

< To add a button to a toolbar:

1 Position the pointer on the toolbar and display the popup menu.

20
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2 Select Customize.

The Customize dialog box displays.

ustomize

Click the palette of buttons you want to use in the Select palette group.

4  Choose a button from the Selected palette box and drag it to the
position you want in the Current toolbar box.

If you choose a button from the Custom palette, another dialog box
displays so you can define the button.

FOR INFO For more information, see "Adding a custom button" on
page 23.

Seeing what's available in the PowerBar

PowerBuilder provides several buttons that do not display by default in
the PowerBar, but which you can add. To see what is available, scroll
the list of buttons and select one. PowerBuilder lists the description for
the selected button.

s To move a button on a toolbar:

1  Position the pointer on the toolbar, display the popup menu, and select
Customize.

2 In the Current toolbar box, select the button and drag it to its new
position.

o

s To delete a button from a toolbar:

1  Position the pointer on the toolbar, display the popup menu, and select
Customize.
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Resetting a toolbar

2 In the Current toolbar box, select the button and drag it outside the
Current toolbar box.

You can restore the original setup of buttons on a toolbar at any time.

To reset a toolbar:

1 Position the pointer on the toolbar, display the popup menu, and select
Customize.

2 Click the Reset button, then Yes to confirm, then OK.

Clearing or deleting a toolbar

22

o,
0.0

‘Whenever you want, you can remove all buttons from a toolbar. If you don’t
add new buttons to the empty toolbar, the toolbar is deleted. You can delete
both built-in toolbars and toolbars you’ve created.

To recreate a toolbar

If you delete one of PowerBuilder’s built-in toolbars, you can recreate it
easily. For example, to recreate the PowerBar, select PowerBarl1 in the New
Toolbar dialog box.

FOR INFO  For information about creating new toolbars and about the
meaning of PowerBarl, see "Creating new toolbars" on page 25.

To clear or delete a toolbar:

1 Position the pointer on the toolbar, display the popup menu, and select
Customize.

2 Click the Clear button, then Yes to confirm.
The Current toolbar box in the Customize dialog box is emptied.

3 Select new buttons for the current toolbar and click OK.
or
Click OK to delete the toolbar.
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Adding a custom button

You can add a custom button to a toolbar. A custom button can:

L

* & & o

02

1

4

Invoke a PowerBuilder menu item

Run an executable (application) outside PowerBuilder
Run a query or report

Place a user object in a window or in a custom user object

Assign a display format or create a computed field in a DataWindow
object

< To add a custom button:

Position the pointer on the toolbar, display the popup menu, and select
Customize.

Select Custom in the Select Palette group.
The custom buttons display in the Selected Palette box.

Select a custom button and drag it to where you want it in the Current
toolbar box.

The Toolbar Item Command dialog box displays. Different buttons
display in the dialog box depending on which toolbar you are
customizing:

Fill in the dialog box as follows:
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To have the button

Do this

Invoke a
PowerBuilder menu
item

Type @MenuBaritem.Menultem in the Command
Line box. For example, to have the button mimic
the Open item on the File menu, type @File.Open

You can also use a number to refer to a menu item.
The first item in a dropdown/cascading menu is 1,
the second item is 2, and so on. Separator lines in
the menu count as items. Example: @Edit.Align
Controls.5

Run an executable
outside PowerBuilder

Type the name of the executable in the Command
Line box. Specify the full path name if the
executable is not in the current search path

To search for the filename, click the Browse button

Run a query

Click the Query button and select the query from
the displayed list

Run a report (same as
previewing a
DataWindow object)

Click the Report button and select a report
(DataWindow) from the displayed list. You can
then specify command-line arguments in the
Command Line box, as described below

Select a user object
for placement in a
window or custom
user object

(Window and User Object painters only) Click the
UserObject button and select the user object from
the displayed list

Assign a display
format to a column in
a DataWindow object
or report

(DataWindow and Report painters only) Click the
Format button to display the Display Formats
dialog box. Select a data type, then choose an
existing display format from the list or define your
own in the Format box

FOR INFO  For more about specifying display
formats, see Chapter 16, "Displaying and
Validating Data"

Create a computed
field in a
DataWindow object
or report

(DataWindow and Report painters only) Click the
Function button to display the Function for
Toolbar dialog box. Select the function from the
list

In the Item Text box, specify the text associated with the button in two
parts separated by a comma: the text that displays on the button and
text for the button's PowerTip:

ButtonText, PowerTip

For example:
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Save, Save File

If you specify only one piece of text, it is used for both the button text
and the PowerTip.

6 In the Item MicroHelp box, specify the text to appear as MicroHelp
when the pointer is on the button.

Supplying arguments If you defined the button to run a report, you can specify arguments in the
with reports command line in the Toolbar Item Command dialog box.

Argument Meaning

/1 LibraryName Specifies the library containing the report

/o ReportName Specifies the report

lig Runs the report

fro Runs the report but does not provide design mode for

modifying the report
/a "Arguments" Specifies arguments t“oipass to the report

The default command line is:

Report /o ReportName /ro

Modifying a custom button

7

+ To modify a custom button:

1  Position the pointer on the toolbar, display the popup menu, and select
Customize.

2 Double-click the button in the Current toolbar box.
The Toolbar Item Command dialog box displays.

3 Make your changes, as described in "Adding a custom button" on page
23.

Creating new toolbars

PowerBuilder has built-in toolbars. When you start PowerBuilder, you see
what is called the PowerBar. In each painter, you also see what is called the
PainterBar. But PowerBar and PainterBar are actually types of toolbars you
can create to make working in PowerBuilder easier.
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PowerBars and A PowerBar is a toolbar that always displays in PowerBuilder, unless you hide
PainterBars it. A PainterBar is a toolbar that always displays in the specific painter for
which it was defined, unless you hide it:

For this toolbar type | The default is named | And you can have up to

PowerBar PowerBarl 4 PowerBars

PainterBar PainterBarl 8 PainterBars in each painter
Where you create You can create a new PowerBar anywhere in PowerBuilder, but to create a new
them PainterBar, you must be in the workspace of the painter for which you want to

define the PainterBar.

K2

% To create a new toolbar:

1 Position the pointer on any toolbar, display the popup menu, and select
New.

The New Toolbar dialog box displays.

About the StyleBar

In painters that don’t have a StyleBar, StyleBar is on the list in the New
Toolbar dialog box. You can define a toolbar with the name StyleBar,
but you can only add painter-specific buttons, not style buttons, to it.

2 Select a PowerBar name or a PainterBar name and click OK.
The Customize dialog box displays with the Current toolbar box empty.

3 One at a time, drag the toolbar buttons you want from the Selected
palette box to the Current toolbar box.
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Using the file editor

PowerBuilder provides a text editor that is always available. Using the editor,
you can view and modify text files (such as initialization files and tab-
separated files with data) without leaving PowerBuilder.

** To open the file editor:

1  Press SHIFT+F6 anywhere in PowerBuilder.
or

Click the Edit button in the PowerBar.

Adding an Edit button
If there is no Edit button on the PowerBar, you can add one. The button
is available from the PowerBar palette.

FOR INFO For more information, see "Customizing toolbars" on page
20.

The File Open dialog box displays.

2 Open the file you want to edit.
or

Click Cancel to display an empty editing workspace.

Setting file editing properties

The file editor has Font and Indentation properties that you can change to make
files easier to read. Select Design>Options from the menu bar to open the
properties sheet. If you don’t change any properties, files have black text on a
white background and a tab stop setting of 3 for indentation.

®,
*

To specify File Editor properties:
1  Select Design>Options to display the property sheet.

2 Choose the tab appropriate to the property you want to specify.

Editor properties apply elsewhere

When you set properties for the file editor, the settings also apply to the
Function, Script, and Database Administration painters and the Debug
window.
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Editing activities
The file editor provides a full set of basic editing facilities including:
¢ Opening, saving, and printing files
¢ Cutting, copying, pasting, and clearing selected text

Finding and replacing text

Undoing changes

Commenting and uncommenting lines

Importing and exporting text files

* & & o o

Dragging and dropping text

Using the file editor’s PainterBar and menu bar

The file editor has a PainterBar that provides a shortcut for performing
frequently used activities. There is also a corresponding menu item (and often
a shortcut key) for each activity:

Menu item Shortcut key | Activity

Edit>Undo CTRL+4Z Undoes the most recent edit

Edit>Cut CTRL+X Cuts selected text to the clipboard

Edit>Copy CTRL+C Copies selected text to the
clipboard

Edit>Paste CTRL+V Pastes the contents of the

clipboard at the current cursor
location; replaces any selected text

Edit>Clear DELETE Deletes selected text; does not
place the text in the clipboard

Edit>Select All CTRL+A Selects all text in the workspace

Edit>Comment Selection — Comments out the current line or
all lines containing selected text
by inserting two slashes before
the first character in each line

Edit>Uncomment Selection | — Uncomments the current line or
all lines containing selected text
by removing the two slashes
before the first character in each
line
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Menu item Shortcut key | Activity

Search>Find CTRL+F Specifies a string for which you
want to search

Search>Find Next CTRL+G Finds the next occurrence of the
specified search string

Search>Replace CTRL+H Replaces the specified search

string

Search>Go to Line

Goes to a specific line number

On Macintosh On the Macintosh, use the COMMAND key instead of the

CTRL key.

On UNIX On UNIX systems, you can also use the middle mouse button and
dedicated editing keys on your keyboard for copying and pasting text if
your window manager supports them.

Dragging and dropping text

To move text, simply select it, drag it to its new location, and drop it. To copy
text, press the CTRL key while you drag and drop the text.

On Macintosh

On the Macintosh, use the COMMAND key instead of the CTRL key.

Executing AppleScript scripts on the Macintosh

®,
0'0

On the Macintosh, you can execute an AppleScript script (either in source or

compiled form) from within the file editor.

To open an AppleScript file for execution:

1 Open the file editor.

2 Do one of the following:

¢ Select File>Open from the menu bar and select a source file
containing AppleScript.
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¢ Type the name of a file in the empty file editor (do not enclose the
filename in quotation marks). The file can be either a source file
containing AppleScript or a compiled AppleScript script.

¢ Create a new script by typing AppleScript commands in the file
editor. You can save the new script using File>Save from the menu
bar.

To execute an AppleScript script:
¢ Select Edit>Execute AppleScript from the menu bar.

The contents of the file editor are executed as an AppleScript script. If
you have typed the name of a file in the editor, PowerBuilder executes
the script in the specified file.

PowerBuilder displays a dialog box with the results.

Executing AppleScript scripts during execution
You can use the DoScript function to execute an AppleScript script during
execution.

FOR INFO For more information, see the PowerScript Reference.
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Changing fonts

The following table summarizes the various ways you can change the fonts

used in PowerBuilder:

For this object or painter

Do this

A table’s data, headings,
and labels

In the Database or Table painter, display the
table’s property sheet, and change the font
properties on the Data, Heading, and Label Font
tabs

Objects in the Report,
Window, and DataWindow
painters

Select objects and then modify settings in the
StyleBar

or

Select an object, display its property sheet, and
change the font properties on the Font tab

Application, Menu, and
Library painters, Browser,
and MicroHelp

Click the System Options button on the
PowerPanel and change the font properties on the
Font tab

Function, Script, and
Database Administration
painters and the file editor
and Debug window
(changes made for one of
these apply to all)

Select Design>Options from the menu bar to
display the editor’s property sheet and change the
font properties on the Font tab. In the Debug
window, select Debug>Options

Changes you make in the System Options dialog box and from the
Design>Options menu selection are reflected in the PowerBuilder initialization
file and are used the next time you open PowerBuilder.
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Defining colors

You can define custom colors to use in most painters and in objects you create.

% To define custom colors:

1 In a painter that uses custom colors, select Design>Custom Colors
from the menu bar.

The Color dialog box displays:

2 Define your custom colors:

Area of the
Color dialog box | What you do

Basic colors Click the basic color closest to the color you want to define
to move the pointer in the color matrix and slider on the righ

Custom colors Modify an exiting color—click a custom color, then modify
palette the color matrix and slider. Define a new color—click an
empty box, define the color, and click Add to Custom Colors

Color matrix Click in the color matrix to pick a color

Color slider Move the slider on the right to adjust the color's attributes
Add to Custom After you have designed the color, click this button to add
Colors button the custom color to the Custom colors palette on the left
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Managing the initialization file

When you start PowerBuilder, it looks for the PowerBuilder initialization file
to set up your environment.

About the initialization file

Specifying
preferences

Format of INI files

The initialization file is a text file that contains variables that specify your
PowerBuilder preferences. These preferences include things such as the last
database you connected to, the PBL you are using, and your toolbar settings.
When you perform an action in PowerBuilder, PowerBuilder writes your
preferences to the initialization file automatically.

Normally, you don't need to edit the initialization file. You can specify all your
preferences by taking an action, such as resizing a window or opening a new
application, or by selecting Design>Options from one of the painters. But
sometimes a variable doesn't appear by default in the options sheet for the
painter. So if you don't see a variable whose value you want to change, use a
text editor such as the PowerBuilder file editor to add the variable to the
appropriate section of the initialization file.

Editing the initialization file

Do not use a text editor to edit the PowerBuilder initialization file or any
preferences file accessed by Profile functions while PowerBuilder or your
application is running. PowerBuilder caches the contents of initialization
files in memory and overwrites your edited PowerBuilder initialization file
when it exits, ignoring changes.

The PowerBuilder initialization file uses the Windows INI file format on all
platforms. It has three types of elements:

+ Section names, which are enclosed in square brackets
¢ Keywords, which are the names of preference settings

¢ Values, which are numeric or text strings, assigned as the value of the
associated keyword

A variable can be listed with no value specified, in which case the default is
used.
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Default sections

Where the
initialization file is
kept

34

The sections in the initialization file and the variables in each section can be in
any order, but the variables that belong to a particular section must be in that
section.

Here are some of the sections and what they contain:

Section What it contains

The name and location of the current application and
PowerBuilder library, and a history of previous applications

Application

PB Basic toolbar, window size, and code generation preferences
as well as the names of the most recently opened objects

Database The current database profile, the list of available DBMSs, and
other Database painter preferences

DBMS_Profiles | The name of the current database profile and a list of previous
profiles

The database profile called name. An additional Profile
section is created for each database profile you define

Profile name

Debug The current Debug window layout, any saved layouts, and the
current breakpoints and watch expressions

Some sections are always present by default, but others are created only when
you specify different preferences. The default initialization file may contain a
section for specific painters: for example, the Data Window section contains
preferences for the DataWindow painter and Report painter, and the SQL
Painter section contains preferences for the SQL Select painter.

If you specify preferences for another painter or tool, PowerBuilder creates a
new section for it at the end of the file. Customized toolbar layouts are also
saved in separate Toolbar sections at the end of the file.

The default PowerBuilder initialization file has different names and is stored in
different locations on each platform:

Platform Name Default location of the initialization file

Windows | PB.INI The directory where PowerBuilder is installed

UNIX .pb.ini Your home directory. You also need a copy of the

.WindU initialization file in your home directory

Macintosh | PowerBuilder | System Folder:Preferences:Powersoft 6.0
Preferences Preferences
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Telling PowerBuilder
where your
initialization file is

How PowerBuilder
finds the initialization
file

If the initialization file
is missing

On Windows and UNIX, you can keep your initialization file in another
location and tell PowerBuilder where it can find it by specifying the location in
the System Options tab dialog. You may want to do this if you use more than
one version of PowerBuilder or if you are running PowerBuilder over a
network.

On Macintosh
On the Macintosh, changing the initialization path in the System Options
dialog box has no effect.

To record your initialization path:
1  Open the PowerPanel and click the System Options button.
The Systems Options dialog box displays.

2 Enter the path of your initialization file in the Initialization Path
textbox.

On Windows, PowerBuilder records the path in the Windows registry.
On UNIX, it records it in a file called reg.dat in your home directory.

On Windows, PowerBuilder looks in the Windows Registry for a path to the
file, and then looks for the file in the directory where PowerBuilder is installed.
If PowerBuilder cannot find the initialization file using the path in the Registry,
it clears the path value.

On UNIX, PowerBuilder looks in the reg.dat file in your home directory for a
path to the file. If it doesn’t find one, it looks for the file in your home directory
and then in the directory where PowerBuilder is installed.

On the Macintosh, PowerBuilder looks in System Folder:Preferences:
Powersoft 6.0 Preferences.

If PowerBuilder doesn’t find the initialization file in the default location when
it starts up, it recreates it. However, if you want to retain any preferences you
have set, such as database profiles, keep a backup copy of your initialization
file. The recreated file has the default preferences.
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Using the .WindU initialization file on UNIX

Changing .WindU
settings

36

The .WindU file is an initialization file that is unique to PowerBuilder for
UNIX. This file contains settings for Wind/U, a product from Bristol
Technology used to implement PowerBuilder in the UNIX Motif environment.
Like .pb.ini, .WindU resides in your home directory.

The organization and content of the .WindU file correspond closely to the
WIN.INI file in Microsoft Windows. You’ll find many of the same sections,
such as [devices] and [ports]. Each section has one or more entries with
appropriate settings assigned to them. The .WindU file also contains some
unique sections of its own.

For most of the sections in the .WindU file, the default settings provided should
meet your needs. If you do want to change any of them, use any text editor.

Making changes in .WindU can give you control over such things as:

¢  Printer configuration

Alternative

If you don’t want to edit the .WindU file bookly, you can use the
File>Printer Setup menu command in PowerBuilder to specify your
printer configuration settings. This displays dialog boxes you can fill in
and updates .WindU automatically.

¢ Font mapping and performance
¢ Common dialog style

FOR INFO  For details on what you should change in the .WindU file to
meet your particular requirements, look in the online Help file named
windu.hlp (by opening it from HyperHelp).



Chapter 1 Working with PowerBuilder

Building an application

This section describes the basic steps you follow when building a
PowerBuilder application. After completing step 1, you can work in any order.
That is, you can define the objects used in your application in any order, as you
need them.

Using other books
This book tells you how to use PowerBuilder painters and tools.

FOR INFO For an overview of the kinds of applications you can build in
PowerBuilder and the building blocks you can use, see the Feature Guide.

FOR INFO  For complete information about the process of building
applications in PowerBuilder, see Application Techniques.

.

%+ To build an application:
1 Create the Application object

This is the entry point into the application. The Application object
names the application, specifies which libraries to use to save the
objects, and specifies the application-level scripts.

FOR INFO See Chapter 2, "Working with Applications".
2 Create windows

Place controls in the window and build scripts that specify the
processing that will occur when events are triggered.

FOR INFO See Part 3, "Working with Windows".
3 Create DataWindow objects

Use these objects to retrieve data from the database, format and
validate data, analyze data through graphs and crosstabs, create reports,
and update the database.

FOR INFO See Part 4, "Working with Databases".
4  Create menus

Menus in your windows can include a menu bar, dropdown menus, and
cascading menus. You can also create popup menus in an application.
You define the menu items and write scripts that execute when the
items are selected.

FOR INFO  See Chapter 10, "Working with Menus".
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Create user objects

If you want to be able to reuse components that are placed in windows,
define them as user objects and save them in a library. Later, when you
build a window, you can simply place the user object instead of having
to redefine the components.

FORINFO See Chapter 11, "Working with User Objects".
Create functions and structures

To support your scripts, you probably want to define functions to
perform processing unique to your application and structures to hold
related pieces of data.

FOR INFO See Chapter 5, "Working with User-Defined Functions", and
Chapter 6, "Working with Structures”.

Test and debug your application

You can run your application at any time. If you discover problems,
you can debug your application by setting breakpoints, stepping
through your code, and looking at variable values during execution.
You can also create a trace file when you run your application and use
PowerBuilder’s profiling tools to analyze the application’s performance
and logical flow.

FOR INFO See Chapter 25, "Debugging and Running Applications".
Prepare an executable

When your application is complete, you prepare an executable version
to distribute to your users.

FOR INFO See Chapter 26, "Creating an Executable".
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Starting PowerBuilder from the command line

On Windows

On UNIX

Opening an object

On Windows and UNIX systems, you can start PowerBuilder from a command
line (or the Windows 95 Run dialog box) and optionally open one of the
following painters or tools:

Application painter Library painter
Database painter Menu painter
Data Pipeline painter Query painter
DataWindow painter Report painter
Debug window Structure painter
File Editor

Function painter Window painter

To start PowerBuilder and open a painter on Windows, use the following
syntax:

{ win } directonA\pb60.exe /P paintername

The use of win is required to start PowerBuilder from the MS-DOS prompt.

To start PowerBuilder and open a painter on UNIX, use the following syntax:
{directory/}pb60 /P paintername
The location of the pb60 executable should be in your PATH environment
variable, so that the directory is usually not required.
You can also add one or more of the following optional switches to the
command line to open a specific object or create a new one:
{/L libraryname} {/O objectname} {/N} {/{R} {/{RO} {/A arguments}

All of these switches must follow /P paintername on the command line, as
shown in the examples after the tables.

Switch | Description

/P Opens the specified painter

/L Identifies the library that contains the object you want to open

/0 Identifies the object, such as a report or window, you want to open
/N Creates a new report
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Switch | Description

/R Runs the DataWindow object or report specified with /O and allows
designing
/RO Runs the DataWindow object or report specified with /O but does not

allow designing

/A Provides arguments for the specified DataWindow object or report

Parameter Description

directory The fully qualified name of the directory containing
PowerBuilder

paintername The name of the painter you want to open. The default is the
window that displays when you begin a new PowerBuilder
session

The painter name must uniquely identify the painter. You do not
have to enter the entire name. For example, you can enter q to
open the Query painter and datab to open the Database painter.
If you enter the full name, omit any spaces in the name (enter
UserObject and DataPipeline, for example)

The painter name is not case sensitive. To open the file editor,
you could set paintername to Fl or fileeditor

libraryname The name of the library that contains the object you want to
open. The default is the library specified in the DefLib variable
in the [PB] section of the PowerBuilder initialization file

objectname The name of the object you want to open

Examples The following examples use pb6 to represent the directory where
PowerBuilder is installed.

Enter this command at the Windows MS-DOS prompt to start PowerBuilder
and open the Database painter:

win pb6\pb60.exe /P datab

Enter this command in the Windows 95 Run dialog box to start PowerBuilder
and open the DataWindow object called d_emp_report in the library
master.pbl:

pb6\pb60.exe /P dataw /L master.pbl /O d_emp_report

Enter this command in the Windows 95 Run dialog box to start PowerBuilder,
open the report called sum_report in the Report painter, and run it:

pb6\pb60.exe /P report /O sum_report /R
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Enter this command in a UNIX terminal window to start PowerBuilder and
open the menu m_frame in the Menu painter:

pb60 /P m /O m_frame
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About this chapter

Contents

Working with Applications

In PowerBuilder, you are always working within the context of an
application. The entry point to an application is the Application object.

This chapter describes Application objects.

Topic Page
Overview of Application objects 44
Creating a new Application object 45
Working with other Application objects 48
Using the Quick Application feature 49
Looking at an application's structure 50
Specifying application properties 54
Writing application-level scripts 62

43



Overview of Application objects

Overview of Application objects

Events in the
Application object

44

An application is a collection of PowerBuilder windows that perform related
activities. It is what you deliver to your users.

The Application object is the entry point into the windows that perform these
activities. It is a discrete object that is saved in a PowerBuilder library, just like
a window, menu, function, or DataWindow object. When a user runs the
application, the scripts you write for events are triggered in the Application
object.

The Application object defines application-level behavior, such as which
libraries contain the objects that are used in the application, which fonts are
used by default for text, and what processing should occur when the application
begins and ends.

When a user runs the application, an Open event is triggered in the Application
object. The script you write for the Open event initiates the activity in the
application. Typically it sets up the environment and opens the initial window.

When a user ends the application, a Close event is triggered in the Application
object. The script you write for the Close event usually does all the cleanup
required, such as closing a database or writing a preferences file.

If there are serious errors during execution, a SystemError event is triggered in
the Application object.

FOR INFO  For a more detailed explanation of PowerBuilder Application
objects, see PowerBuilder Getting Started.
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Creating a new Application object

The first step in building a new PowerBuilder application is to create an
Application object for the application. In the Application object, you:

¢  Assign the application a name and icon

¢ Establish the default text colors, sizes, styles, and fonts for the
application

¢ Specify the libraries the application can use, in the sequence in which
you want them to be searched during execution

¢ Build the application-level scripts

You use the Application painter to create an Application object and specify its
properties.

Using an existing Application object
If you want to work with an existing application, see "Working with other
Application objects" on page 48.

% To create an Application object:
1 Click the Application painter button in the PowerBar or PowerPanel.
The Application object opens and displays in the workspace.
2 Select File>New from the menu bar.
The Select New Application Library dialog box displays.

3 Specify the PowerBuilder library in which you want to store the
Application object and click Save.

The application itself can use multiple libraries. The library you are
specifying here is the library in which to store the Application object.
You can name a new library or specify an existing library.

The Save Application dialog box displays.
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Putting more than one Application object in a library

Any Application objects in the specified library are listed in the second
box in the Save Application dialog box. Standard practice is to have no
more than one Application object in a library, although you can have
more. For ease of migrating applications to new versions of
PowerBuilder, you should have only one Application object in a
library. If the library you have chosen already has an Application
object, you might want to click Cancel and choose another library.

Name the Application object.

Enter a 1- to 40-character name for the application you are building.
The Application object name will display in the PowerBuilder title bar
while you are working on the application.

Using an existing name

If you create a new application with the same name as an application
that already exists in the PBL, PowerBuilder overwrites the existing
application. It does not remove any other objects from the PBL,
because they may be referenced by another application.

(Optional) In the Comments box, enter comments to document the
application you are building and to help other developers understand
the application.

E Save Application

The comments display in the Library painter.
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6  Click OK.

The Application dialog box displays, asking whether you want to build
a template for your application.

FOR INFO  For more information, see "Using the Quick Application
feature" on page 49.

7  Click Yes to generate a template for your application.
or

Click No to start your application from scratch.

You go to the Application painter workspace. The new Application
object is displayed as an icon in the workspace.

You have created the Application object and placed it in a PowerBuilder
library. You now need to define the Application object's properties.

FOR INFO  For how, see "Specifying application properties" on page 54.
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Working with other Application objects

When you open the Application painter, PowerBuilder opens and displays the
Application object you worked on last. You can switch to work with another
Application object (and thus work on another application) at any time.
< To work with another Application object:
1 Open the Application painter.
The last Application object you worked with opens.

2 Click the Open button.
or

Select File>Open from the menu bar.
The Select Application Library dialog box displays.
3 Select the library containing the Application object and click Open.

The Save Application dialog box displays the Application objects in
the specified PowerBuilder library.

4  Choose the Application object from the list.

You can choose an Application object from a different PowerBuilder
library by clicking the Other button.

The chosen Application object opens and displays in the workspace.
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Using the Quick Application feature

For more information

When you are creating a new Application object, PowerBuilder offers to create
an application template for you.

You can use this template to begin your application, instead of having to define
all of your objects from scratch.

If you click Yes, PowerBuilder generates the shell of a basic Multiple
Document Interface (MDI) application that includes an MDI frame (complete
with window functions that do such things as open or close a sheet), a sheet, an
About dialog box, menus, toolbars, and scripts.

The Application painter workspace shows the objects in the application, as
described in the next section.

You can run the application immediately by clicking the Run button on the
PainterBar. You can open sheets, display an About box, and select items from
menus.

You can use this application as a starting point for your MDI application.

For more information about building MDI applications, see Application
Techniques.

For more information about MDI frames on the Macintosh, see "Window types
on the Macintosh" on page 166.
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Looking at an application's structure

K/
*

Once you have selected an Application object, it displays as an icon in the
Application painter workspace. If you are working with an application that
references one or more objects in an application-level script, you can look at
the application's structure in the Application painter.

To display the application's structure:

1 Open the Application painter and select the Application object you
want to work with.

The Application object displays as an icon in the workspace.

2 Double-click the icon.

PowerBuilder expands the display to show all the global objects that
are referenced in a script for the Application object.

FORINFO For complete information about exactly which objects are
shown in the workspace, see "Which objects are displayed" on page 51.

utrans_maindb
HE & u_global_vars
E@-E} w_startup_ord

3 Work with the objects in the workspace, as described next.

Working in the workspace

Working with
inherited objects

50

The Application painter workspace displays referenced objects in an outline
format. A popup menu offers shortcuts to working with each displayed object.

An asterisk following an object’s name in the workspace indicates that the
object is a descendant of another object.
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0,

«* To see the inheritance hierarchy for a descendent object:
¢ Select Inheritance Hierarchy from the popup menu.

PowerBuilder displays a window showing the inheritance hierarchy for
the selected object.

w_expenses_nanvisual
w_expenses_restricted

Which objects are displayed

The Application painter workspace shows global objects that are referenced in
your application. It shows the same types of objects that you can see in the
Library painter. It does not show entities that are defined within other objects,
such as controls and object-level functions.

Which references are displayed

The workspace displays the following types of references when an object is
expanded.

Objects that are referenced in painters For example:

¢ If a menu is associated with a window in the Window painter, the menu
displays when the window is expanded.

¢ If a DataWindow object is associated with a DataWindow control in
the Window painter, the DataWindow object displays when the
window is expanded.

¢ If a window contains a custom user object that includes another user
object, the custom user object displays when the window is expanded,
and the other user object displays when the custom user object is
expanded.

Objects that are directly referenced in scripts For example:

¢ If a window script contains the following statement:
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Open (w_continue)

Then w_continue displays when the window is expanded.

Which referenced windows display in the workspace

Windows are only considered referenced when they are opened from
within a script. A use of another window's property or instance variable
will not cause the Application painter to display the other window as a
reference of the window containing the script.

¢ If amenu item script refers to the global function f_calc:
f_calc (Enteredvalue)
Then f_calc displays when the menu is expanded.
¢ If a window uses a popup menu through the following statements:

m_new mymenu
mymenu = create m_new
mymenu.m_file.PopMenu (PointerX(), PointerY())

Then m_new displays when the window is expanded.

Which references are not displayed

The workspace does not display the following types of references.

Objects that are referenced only through instance variables or
properties For example:

¢ If w_go has this statement (and no other statement referencing w_emp):
w_emp.Title = "Managers"
Then w_emp does not display as a reference for w_go.

Objects that are referenced dynamically through string variables For
example:

¢ If a window script has the following statements:

window mywin

string winname = "w_go"
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Open (mywin,winname)

Then the window w_go does not display when the window is
expanded. The window w_go is named only in a string.

If the DataWindow object d_emp is associated with a DataWindow
control dynamically through the following statement:

dw_info.DataObject = "d_emp"

Then d_emp does not display when the window containing the
DataWindow control is expanded.
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Specifying application properties
The Application object specifies the following properties of the application:
¢ "Specifying default text properties" on page 55
¢ "Specifying the library search path" on page 57
¢ "Specifying an icon" on page 59
¢ "Specifying default global objects" on page 60

You specify all these properties in the Application painter property sheets.

Using the application properties tab

Ol

** To specify application properties:

1 Select Properties from the application's popup menu.

2 Choose the tab of the property you want to specify:

To specify Choose this tab

The default font for static text as it appears in Text Font
windows, user objects, and DataWindow objects
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To specify Choose this tab
The default font for data retrieved in a DataWindow Column Font
object

The default font for column headers in tabular and grid | Header Font
DataWindow objects

The default font for column labels in freeform Label Font
DataWindow objects

The application icon Icon
Global objects for your application Variable Types
An application search path Libraries

All of these properties are discussed below.

Specifying default text properties

You probably want to establish a standard look for text that is in your
application. There are four kinds of text whose properties you can specify in
the Application painter: text, header, column, and label.

PowerBuilder provides default settings for the font, size, and style for each of
these and a default color for text and the background. You can change these
settings for an application in the Application painter and can override the
settings for a window, user object, or DataWindow object.

Properties set in the Database painter override application properties
If extended attributes have been set for a database column in the Database
painter or Table painter, those font specifications override the fonts
specified in the Application painter.

o

< To change the text defaults for an application:

1  Select Properties from the application's popup menu and select one of
the following:

¢ Text Font tab
¢ Header Font tab

¢ Column Font tab
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¢ Label Font tab

The tab you choose displays the current settings for the font, size, style,
and color.

MS Dialog

MS Dialog Light

(3 MS Li
M

The text in the Sample box illustrates the current settings.
2 Review the settings and make any necessary changes:
¢ To change the font, select a font from the list in the Font listbox.

¢ To change the size, select a size from the list in the Size listbox or
type a valid size in the listbox.

¢ To change the style, select a style (Regular, Italic, Bold, or Bold
Italic) from the Font styles listbox.

¢ To change font effects, select one or more from the Effects group
box (Strikeout and Underline).

¢ To change the text color, select a color from the Text Color
listbox. (You don't specify colors for data, headings, and labels
here. You do that in the DataWindow painter.)

¢ To change the background color, select a color from the
Background listbox.
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Using custom colors

When specifying a text color, you can choose a custom color. You can
define custom colors in several painters, including the Window painter
or DataWindow painter.

3 When you have made all the changes, click OK.

Specifying the library search path

The objects you create in painters are stored in PowerBuilder libraries. You can
use objects from one library or multiple libraries in an application. You define
each library the application uses in the library search path.

PowerBuilder uses the search path to find referenced objects during execution.
When a new object is referenced, PowerBuilder looks through the libraries in
the order in which they are specified in the library search path until it finds the
object.
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< To define a library search path:

1 Select Properties from the application's popup menu and select the
Libraries tab.

The Libraries 'property page displays the current library search path and
lists the PowerBuilder libraries in the current directory.

; Application

.\pbls\proﬂler\prflle.pbl,
D:\pbls\datawindow.pbl;

2 Enter the name of each library you want to include in the Library
Search Path listbox, separating them with semicolons.
or

Use the Browse button to include other libraries in your search path.

Make sure the order is correct

When you select multiple libraries from the Select Library dialog box
using SHIFT+click or CONTROL+click, the first library you select
appears last in the Library Search Path listbox and will be the last
library searched.

To delete a library from the search path, select the library in the listbox
and press DELETE.

3 Click OK.

PowerBuilder updates the search path for the application.
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For more information

Specifying an icon

Where PowerBuilder maintains the library search path
PowerBuilder stores your application's library search path only in your
initialization file. It does not store that information in the Application object.

There is a line in your initialization file's Application section for each
application you have defined; that line lists all libraries in the application's
search path. So if you give the PBLs for an application you are building to
another PowerBuilder developer, make sure you copy the appropriate line
from your initialization file to the other developer's initialization file or that
the other developer opens the Application object and specifies the library
search path as described above. That way the application's library search
path gets defined correctly on the other developer's machine.

There are several strategies you can use to organize your application into
libraries and optimize your environment and easily work with other developers
on a large application.

The Application Techniques book describes these strategies in detail.

Users may minimize your application during execution. If you specify an icon
in the application painter, the icon will display when the application is
minimized.

On Macintosh and UNIX

The icon that you specify in the Application painter does not display when
you run your application on the Macintosh or UNIX platforms. If you are
creating a cross-platform application on these platforms, you can select an
ICO file that will be used when you build your application on Windows.

FOR INFO  For information about specifying Macintosh Finder icons for
your application, see "Macintosh resources" on page 895.

To associate an icon with an application:

1  Select Properties from the application's popup menu and select the Icon
tab.

2 Specify a file containing an icon (an ICO file).
The button displays at the right of the Icon Name box.
3 Click OK to associate the button with the application.
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Specifying default global objects

60

PowerBuilder provides five built-in giobal objects that are predefined in all

applications.

Global object

Description

SQLCA Transaction object, used to communicate with your database
SQLDA DynamicDescriptionArea, used in dynamic SQL

SQLSA DynamicStagingArea, used in dynamic SQL

Error Used to report errors during execution

Message Used to process messages that are not PowerBuilder-defined

events and pass parameters between windows

You can create your own versions of these objects by going to the User Object
painter and defining a standard class user object that inherits from one of the
built-in global objects. You can add instance variables and functions to
enhance the behavior of the global objects.

FOR INFO  For more information, see Chapter 11, "Working with User

Objects".

After you do this, you can tell PowerBuilder that you want to use your version
of the object in your application as the default, instead of the built-in version.

To specify the default global objects:

1 Select Properties from the application's popup menu and select the
Variable Types tab.

The Variable Types property page displays.



Chapter 2 Working with Applications

2 Specify the standard class user object you defined in the corresponding
field.

For example, if you defined a user object named mytrans that is
inherited from the built-in Transaction object, type mytrans in the box
corresponding to SQLCA.

; Application

lynamicdescriptionarea

namicstagingarea

3 Click OK.

When you run your application, it will use the specified standard class user
objects as the default objects instead of the built-in global objects.
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Writing application-level scripts

When a PowerBuilder application is run, an Open event is triggered in the
Application object. You write a script for the Open event that specifies the
processing that takes place when the application is opened. Typically this script
opens the first window of the application and sets up the environment.

Batch applications
If your application performs only batch processing, all processing takes
place in the script for the application Open event.

This table lists all events that can occur in the Application object. The only
event that requires a script is Open.

Event Occurs when
Open The user starts the application
Close The user closes the application. Typically, you write a script

for this event that shuts everything down (such as closing
the database connection and writing out a preferences file)

SystemError A serious error occurs during execution (such as trying to
open a nonexistent window). If there is no script for this
event, PowerBuilder displays a message box with the
PowerBuilder error number and message text. If there is a
script, PowerBuilder executes the script

FOR INFO  For more about error handling, see "Handling
errors during execution" on page 844

Idle The Idle PowerScript function has been called and the
specified number of seconds have elapsed with no mouse or
keyboard activity

ConnectionBegin In a distributed computing environment, a client establishes
a connection to a server by calling the ConnectToServer
function.

ConnectionEnd In a distributed computing environment, a client disconnects

from a server by calling the DisconnectServer function.
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Setting application properties

The Application object has several properties, which specify application-level
properties. For example, the property ToolbarText specifies whether text
displays on toolbars in an MDI application.

You can reference these properties in any script in the application using this
syntax:

AppName.property

For example, to specify that text displays on toolbars in the Test application,
code this in a script:

Test .ToolbarText = TRUE

(If the script is in the Application object itself, you don't need to qualify the
property name with the application name.)

Application name cannot be changed
The name of an application is one of the Application object’s properties, but
you cannot change it.

FOR INFO For a complete list of the properties of the Application object,
see Objects and Controls.
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About this chapter

Contents

Managing Libraries

PowerBuilder stores all the objects you create in libraries. When you work
with an application, you specify which libraries it will use. This chapter

describes how to work with your iibraries.
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Browsing the class hierarchy 81
Using check-out and check-in 83
Optimizing libraries 92
Regenerating library entries 93
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Creating runtime libraries 100
Creating reports on library contents 102
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Overview of libraries

Assigning libraries

How the information
is saved

Using libraries

66

Whenever you save an object, such as a window or menu, in a painter,
PowerBuilder stores the object in a library (a PBL file). Similarly, whenever
you open an object in a painter, PowerBuilder retrieves the object from the

library.

Application painter
Data Pipeline painter
| DataWindow painter Save an object
| Function painter
Menu painter
Project painter
Query painter
Structure painter
User Object painter
Window painter

Library (PBL file)

Stores the objects in
“ the application

Applications can use as many libraries as you want. Libraries can be on your
own PC or workstation or on a server. When you create an application, you
specify which libraries it uses. You can also change the library search path for
an application at any time during development.

FOR INFO For more on assigning libraries to an application, see
"Specifying the library search path" on page 57.

Every object is saved in two parts in a library:

¢ Source form This is a syntactic representation of the object, including
the script code.

¢ Object form This is a binary representation of the object, similar to an
object file in the C and C++ languages. PowerBuilder compiles an
object automatically every time you save it.

It is hard to predict the needs of a particular application, so the organization of
an application's libraries will probably evolve over the development cycle.
PowerBuilder lets you reorganize your libraries easily at any time.

For small applications, you might use only one library. But for larger
applications, you will want to split the application into different libraries.
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About library size

There are no limits to how large libraries can be, but for performance and
convenience, you should follow the guidelines below.

¢ Size Try to keep your libraries smaller than about 800K. If your
libraries are larger, performance can suffer because PowerBuilder has
to search more in order to save or open an object.

¢ Number of objects It is a good idea not to have more than 50 or 60
objects saved in a library. This is strictly for your convenience; the
number of objects doesn't affect performance. But if you have many
objects in a library, you will find that listboxes that list library objects
become unmanageable and that the Library painter becomes more
difficult to use.

¢ Balance You don't want to have to manage a large number of libraries
with only a few objects. That makes the library search path too long
and can slow performance by forcing PowerBuilder to look through
many libraries to find an object. So you should try to maintain a
balance between the size and number of libraries.

Organizing libraries

A recommended
organization

You can organize your libraries any way you want. For example, you might
want to put all objects of one type in their own library. Or you might want to
divide your application into subsystems and place each subsystem in its own
library.

If you are working with other developers on a large application, here is a setup
that works well.

Put libraries containing objects that are shared by developers on a server
rhachine on the network. That way all developers have direct access to them.
Put objects that only you are working on in a library on your PC or workstation.

Here is an example. The following libraries would be publicly available on a
server:

Library Contents

VIRTUAL.PBL | This library contains all ancestor objects used in the
application. For example, if all the windows in your
application inherit from w_master, place w_master in this
library

COMMON.PBL | This library contains all objects that are used across
applications, such as user objects and functions
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Sharing objects with
others

Ordering the
application's library
search path

68

Library Contents
APP1.PBL This library contains objects specific to application 1
APP2.PBL This library contains objects specific to application 2

Also, each developer would have one or more private libraries where they
would keep the objects they are working on.

Bill's PC
WORK PBL
Server / .
f — yd
' VIRTUAL.PBL 4 Cheryl's PC
I yd
w -
| | COMMON.PBL WORK.PBL
APP1.PBL | TEMP.PBL
| m————— K R
1 APP2.PBL
] Terry's PC
.
N | MINE.PBL
w ]
TEST.PBL

PowerBuilder provides check-out/check-in facilities that let you check an
object out of one library, such as APP1.PBL, and store a working copy in
another library, such as your private library. While you have the object checked
out, no one else can modify it. When you finish updating an object, you can
check the object back in to the public library.

If you use the scenario described above with public and private libraries, you
should place the private libraries first in the library search path. Then when you
check an object out of a public library and place it in your private library,
PowerBuilder will find the private one first when executing the application.
When you check the object back in to the public library, it is removed from the
private library and PowerBuilder finds the updated public version when
executing the application.

FOR INFO For more about check-out/check-in, see "Using check-out and
check-in" on page 83.
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Specifying the library
search path

You specify an application's library search path in the Application painter.

FOR INFO  For more information, see "Specifying the library search path”
on page 57.
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Working with libraries

You work with libraries in the Library painter.

Viewing the tree

70

To open the Library painter:

¢ Click the Library painter button in the PowerBar or PowerPanel.

The Library painter displays.

When you open the Library painter, it lists all directories on the current drive.
It expands the current directory and expands the current library (the most
recently used library) to show its entries.

d:

Ypbls
—@ datawindow. pbl
—@ debug.pbl

—@ pbtest.pbl

—a pbtest
— d_richtext
— d_testl
1  m_genapp_frame
—TEf m_genapp_sheet
— @ m_test1

=] sti_test1

B w_genapp_about
= w_genapp_frame
= w_genapp_sheet
= w_genapp_toolbars
— E & w_main
3 @ w_popup

You can expand (display the contents of) libraries and directories. You can also

Test PBL for extemnal functions

07/01/97 08:27:03 07/01/97 08:27:03
06/30/97 17:05:20 06/30/97 17:04:14
06/30/97 17:05:33 06/30/97 17:04:14
02/18/97 16:16:13 06/30/97 17:04:15
02/18/97 16:16:43 06/30/97 17:04:16
06/30/97 17:05:44 06/30/97 17:04:16
06/30/97 17:11:47 06/30/97 17:11:47
02/18/97 16:16:12 06/30/97 17:04:17
02/18/97 16:16:16 06/30/97 17.04.17
02/18/97 16:16:14 06/30/97 17:04:17
02/18/97 16:16:15 06/30/97 17:.04:18
06/30/97 17:06:00 07/01/97 08:28:52
06/30/97 17:06:21 06/30/97 17:04:18

collapse the display of libraries and directories.

To expand a library or directory:

¢  If the library or directory is currently collapsed, double-click the library

or directory.

(2176)

[4024) Datawindow to test RichText
(8364) Basic Datawindow object
(18022) Generated MDI frame menu
(22264) Generated MDI sheet menu
(19292) Menu for main window

863)

4748) Generated About window
(5173) Generated MDI frame window
(3460) Generated MDI sheet window

[16212) Generated toolbar configuration winc .
[1780) Main window for PBE test application

(1533) Basic popup window with 3 buttons

PowerBuilder displays all objects stored in the selected library or the
files and subdirectories in the selected directory.

Each entry in a library has an icon that identifies the painter in which the entry

was created. The icons are the same as those used in the PowerBar.
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«» To collapse a library or directory:

¢ If the library or directory is currently expanded, double-click the library
or directory.

PowerBuilder hides all objects stored in the selected library or the files
and subdirectories in the selected directory.

Using the popup menu
Like the other painters, the Library painter has a popup menu that provides
items that apply to the selected object in the workspace.

.

% To use the popup menu:

Position the mouse pointer on an object listed in the workspace.

[N

Click the right mouse button.

On Macintosh
On the Macintosh, hold down the COMMAND key and press the mouse
button.

The popup menu displays. Which items display on the menu depend on
the type of object you have selected.

3 Select the item you want from the menu.

Limiting the display of library entries
You can change what is shown in expanded libraries. You can specify:
¢ Which objects are displayed

¢ What information is shown for the displayed objects

Settings are remembered

PowerBuilder records your preferences in the Library section of the
PowerBuilder initialization file so that the next time you open the Library
painter, the same objects and information are displayed.
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Specifying which Initially, the Library painter displays all objects in expanded libraries. You can

objects are shown have the painter display only specific kinds of objects and/or objects whose
names match a specific pattern. For example, you can limit the display to only
DataWindow objects, or limit the display to windows that begin with w_emp.

< To restrict which objects are displayed:

1 Select Design>Options from the menu bar and select the Include tab.

2 Specify the display criteria.

+ To limit the display to entries that contain specific text in their
names, enter the text in the Name box. You can use the wildcard
characters question mark (?) and asterisk (*) in the string: ?
represents one character, * represents any string of characters. The
default is all entries of the selected types.

+ To limit the display to specific entry types, clear the checkboxes
for the entry types that you do not want to display. The default is
all entries.

3 Click OK.
The Options property sheet closes.

4 Expand libraries to display the entries that meet the criteria.
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Specifying which Initially, PowerBuilder displays the name, modification date, compilation date,
information is shown size (of the compiled object), check-out status, and comments for displayed
for the displayed entries

objects )

+ To specify which information is displayed:

¢ Select Comments, Modification Date, Compilation Date, Check Out
Status, or Size from the View menu to toggle the display of comments,
dates, check-out status, and sizes.

Selecting library entries

You can select one or more library entries to act on. You can select entries in
different libraries at the same time.

K/

% To select multiple entries:

1 To select noncontiguous entries, press CTRL and click each entry you
want to select.

2 To select contiguous entries, click the first entry you want to select,
press SHIFT, then click the last entry you want to select.

3 To select all entries in a library, select the library, then click the Select
All button.

PowerBuilder highlights selected entries.

Using comments

You can use comments to document your objects and libraries. For example,
you might use comments to describe how a window is used, specify the
differences between descendent objects, or identify a PowerBuilder library.

You can associate comments with an object when you first save it in a painter.
You can use the Library painter to add or modify comments for a saved object.

Modifying comments for saved objects
The Library painter is the only place where you can modify comments for a
saved object.
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Updating library You can update comments for libraries or individual library entries with the
comments following procedure.

o,

< To update comments for an existing PowerBuilder library:

1  Select Properties from the Library's popup menu and select the General
tab.

Properties

est PBL for external functions

2 Add or modify the comments.
3 Click OK.

You return to the Library painter workspace.
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Creating and deleting libraries

R/

1

% To create a library:

Click the Create button.
or

Select Library>Create from the menu bar.

The Create Library dialog box displays showing the current directory
and listing the libraries it contains. This dialog box may look different
on your platform.

Create Library

] datawindow.pbl
debug.pbl

] pbtest.pbl

i profile.pbl
testapp.pbl

Enter the name of the library you are creating and specify the directory
in which you want to store it.

Since you are naming a file, you must follow the operating system rules
on your platform. Make sure the file extension is PBL.

Click Save or OK.

The library property sheet displays.

Enter any comments you want to associate with the library.

It is good practice to add comments to describe the purpose of a library.
Click OK.

PowerBuilder creates the library.
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®,

% To delete a library:
1  Select the library you want to delete.

2 Select Library>Delete from the menu bar.

Restriction
You cannot delete a library that is in the current application's library
search path.

The Delete Library dialog box displays showing the library you
selected.

3 Click Yes to delete the library.

The library and all its entries are deleted. You cannot get them back.

Creating and deleting libraries during execution
You can use the LibraryCreate and LibraryDelete functions in scripts to
create and delete libraries.

FOR INFO For information about these functions, see the PowerScript
Reference.
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Copying, moving, and deleting entries

As the needs of your application change, you will want to be able to rearrange
libraries. Perhaps you are dividing your application into different libraries. To
do that, you will want to copy and move entries between libraries or delete
entries that you no longer need.

K2

1
2

** To copy or move entries to a different library:

Select the entries you want to copy or move to another library.

uw move to anoth I

Click the Copy button or the Move button.
or

Select Entry>Copy or Entry>Move from the menu bar.

The Copy Library Entries dialog box or the Move Library Entries
dialog box displays.

Select the library to which you want to copy or move the entries and
click OK.

If copying, PowerBuilder copies the entries. If moving, PowerBuilder
moves the entries and deletes the entries from the source library. If a
library entry with the same name already exists, PowerBuilder replaces
it with the copied or moved entry.

< To delete entries:

1
2

Select the entries you want to delete.

Click the Delete button.
or

Select Entry>Delete from the menu bar.

You are asked to confirm the first deletion.

Being asked for confirmation

By default, PowerBuilder asks you to confirm each deletion. If you
don't want to have to confirm deletions, select Design>Options to open
the Options property sheet for the Library painter and clear the Confirm
on Delete checkbox.

PowerBuilder records this preference as the DeletePrompt variable in the
Library section of the PowerBuilder initialization file.

Click Yes to delete the entry. Click No to skip the current entry and go
on to the next selected entry.
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Searching library entries

You can search library entries to locate where a specified text string is used in
your application. For example, you can search for:

¢  All scripts that use the SetTransObject function

¢ All windows that contain the CommandButton cb_exit (all controls
contained in a window are listed in the window definition's source form
in the library so can be searched for as text)

¢ All DataWindow objects accessing the Employee table in the database

.,
*

To search library entries for a text string:
1  Select the entries you want to search.

You can select entries across libraries by expanding the libraries and
using SHIFT-click and/or CTRL-click to select multiple entries.

2 Click the Search button.
or

Select Entry>Search from the menu bar.

The Search Library Entries dialog box displays.

3 Enter the string you want to locate (the search string) in the Search For
box.

The string can be all or part of a word or phrase used in a property,
script, or variable. You cannot use wildcards in the search string.

4  In the Display group box, select the information you want to display in
the results of the search.

5  In the Search In group box, select the parts of the object that you want
PowerBuilder to inspect: properties, scripts, and/or variables.
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6 Click OK.

PowerBuilder searches the libraries for matching entries. When the
search is complete, PowerBuilder displays the matching entries in the
Matching Library Entries dialog box.

For example, the following dialog box displays the results of a search
for the string list.

: Malchig Library Entries

Control/Function: updateview
0017: routine.IncomingCallList [incomingCalls, TRUE )
0026: routine. OutgoingCallList [outgoingCalls, TRUE )

ntry Mame: d:\pbls\profile. pbliw_func_summary]
Propetties For: w_func_summary
ProfileRoutine routineList{]

Control/Function: updateview
0011: profilet odel. RoutineList] routineList )

0013: limit = UpperBound( routineList )
0018: routine = routineList[index]

Control/Function: dw_summary
Event Name: doubleclicked
0005: routineD etail(routineList{index])

hiry Name: d:pbls'profile. pblfw_profile)
Control/Function: dumpnode
0003: TraceTreeMode list[], subNode
stllist)
What you can do From the Matching Library Entries dialog box, you can:
¢ Jump to the painter in which an entry was created (described next)
¢  Print the contents of the window

¢ Copy the search results to a text file
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Jumping to a painter

80

You can jump from the Library painter directly to the painter where a specific
entry was created.

« To jump to a painter:

¢ From the Match Library Entries dialog box that resulted from your
browsing entries, double-click the entry.
or

Select the entry, then click the Go To Painter button.

FOR INFO For more on searching entries, see "Searching library
entries" on page 78.

PowerBuilder opens the object in its painter.

Jumping to a painter from the workspace
You can also jump to a painter by double-clicking an entry in the
Library painter workspace.

You can view the object and make changes as needed in the painter. When you
close the painter, PowerBuilder returns you to the point in the Library painter
from which you initiated the jump.

Library must be in current list
You can open and search any object that displays in the Library painter
workspace, but you can only modify objects in libraries that are in your
application’s current library list.
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Browsing the class hierarchy

You have probably used inheritance to define hierarchies of windows, menus,
and user objects. You can examine these hierarchies using the Browser. In
object-oriented terms, these are called class hierarchies: each PowerBuilder
object defines a class.
To browse the class hierarchies:
1 Click the Browse button in the PowerBar.

The Browser displays.
2 Choose the System tab to show the built-in PowerBuilder objects.

3 Display the popup menu in the object panel of the Browser and choose
Show Hierarchy.

4 Select powerobject and choose Expand All from the popup menu.

: Browser

@2F Properties
application Events
[84 function_object Functions
& agraphicobject :

T menu
"8 menucascade
E window

=i @8 windowobject
=i @@ dragobject
. -~ checkbox
I commandbutton
.. picturebutton
© LB datawindow
. = diopdownlistbox
: dropdownpictureli
-l graph -
&7, mraumbe

PowerBuilder displays the hierarchy for built-in PowerBuilder objects.

Getting context-sensitive Help in the Browser
To get context-sensitive Help for an object, control, or function, select
Help from its popup menu.
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K/
*

To display the class hierarchy for other object types:
1  Choose a tab for another object type (for example, the Menu tab).

2 Select an object in the object panel and choose Show Hierarchy from
its popup menu.

If there is no inheritance for the object type, Show Hierarchy is grayed
out.

3 Select an object and choose Expand All from its popup menu.

PowerBuilder shows the selected object type in the current application.
Descendent objects are shown indented under their ancestors.

Regenerating objects The Browser provides a convenient way to regenerate objects and their
descendants.

FOR INFO  For more information, see "Regenerating library entries" on page

93.
Another way to You can also access a class browser for a specific object type when you are
browse hierarchies defining an inherited window, menu, or user object.

< To display the class hierarchy for a specific object type:

1 Open the Window painter, Menu painter, or User Object painter.
2 Click the Inherit button in the Select dialog box.

3 Click the Browse button in the Inherit From dialog box.

A class browser opens showing the inheritance hierarchy of objects of
the specific object type.
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Using check-out and check-in

If you are working with other developers on a large application, you will want
toprevent multiple developers from modifying a library entry at the same time.
To control access to library entries, PowerBuilder provides check-out and
check-in facilities. Using them, you can check an object out of a public library
and store a working copy in a private library. While the object is checked out,
no one can modify it in the public library. When you finish updating an object,
you can check the object back in to the public library.

FOR INFO For more about setting up libraries to support this type of
development environment, see "Overview of libraries" on page 66 and
Application Techniques.

About PowerBuilder and version control systems

On Windows and Macintosh systems, PowerBuilder provides interfaces to
external version control systems so that you can manage your PowerBuilder
objects through an external system while developing PowerBuilder
applications. Most of the items on the Source menu in the Library painter
apply only if you are using a version control system.

FOR INFO  For more about using PowerBuilder with external version
control systems, see Version Control Interfaces.

The check-out and check-in facilities described in this section are available
even if you are not using a version control system to manage PowerBuilder
objects.

How check-out works

When you want to work on an object and prevent others from making changes
to the object, you check it out.

When you check out a library entry, PowerBuilder:

¢ Makes a working copy of the entry in a specified library (such as a
private test library)

¢ Sets the status of the original entry to checked out

As long as the status of a library entry is checked out, changes can be made
only to the working copy. If you or another user tries to open the original,
PowerBuilder displays a message box warning that the entry is checked out and
can be opened but not saved.
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How check-in works

When you finish working with an entry that you checked out, you check the
entry back in. PowerBuilder:

¢ Replaces the entry in the library from which you checked it out with
the working copy

¢ Deletes the working copy from the library to which you checked it out

If you don't want to use the checked-out version

Instead of checking an entry back in, you can choose not to use the checked-
out version by clearing the check-out status of the entry in the original
library and deleting the working copy.

Connecting to a version control system

K/

% To connect to a version control system:
1 Select Source>Connect from the menu bar.
The Connect dialog box displays.
2 Select a version control vendor from the Vendors dropdown list.
Supported source control vendors are:
ObjectCycle from Powersoft
CCC from Softool
ENDEVOR from Computer Associates
PVCS Version Manager from INTERSOLV
Source Integrity from MKS

* & & o o o

Apple Source Server
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In addition to these vendors, (PB Native) and SCC API display in the
dropdown listbox.

(PBNative) is the identifier for PowerBuilder's native check-out and
check-in facilities in the Library painter. If you select (PB Native) and
click OK, the Set Current User ID dialog box displays. This allows you
to enter or change a user ID to identify who checked out a
PowerBuilder object.

SCC API is PowerBuilder’s Source Code Control common API. It
provides a standard interface to any version control system that
implements features defined in the Microsoft Common Source Code
Control Interface Specification.

FOR INFO  For more about using PowerBuilder with external version
control systems, see Version Control Interfaces.

Checking out entries

Checking out the Application object
Always check out the Application object by itself; PowerBuilder performs
unique tasks when you check out the Application object.

FOR INFO See "Working with the Application object” on page 90.

To check out entries:

1
2

Select the entries you want to check out.

Click the Check Out button.
or
Select Source>Check Out from the menu bar.
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86

If this is the first time you have checked out an entry, the User ID
dialog box displays. Enter your user ID and click OK.

PowerBuilder saves your ID as the variable UserID in the Library
section of the PowerBuilder initialization file and will not prompt you
for an ID again unless you select Source>Connect from the menu bar.
PowerBuilder uses the ID to identify who checked out objects.

The Check Out Library Entries dialog box displays the current
directory and lists the libraries in that directory. The appearance of this
dialog box depends on your platform.

<] datawindow.pbl
debug.pbl
pbtest.pbl

] profile.pbl

? testapp.pbl

Enter the name of the library in which you want to save the working
copy in the File Name box or select the library from the list of libraries.

You must specify a library in the current application's library search
path or you won't be able to save the working copy later.

Click Open.

If you selected an entry that another user has checked out,
PowerBuilder displays a message box and asks if you want to continue.
Click Yes to process any remaining entries.

PowerBuilder makes a working copy of each selected entry and stores
it in the destination library you specified.
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Checked-out items
shown in workspace

The Library painter workspace marks with icons objects that have been
checked out and objects that are working copies.

For example, the following shows that six windows have been checked out of
PBEXAMW2.PBL:

|— #%R phexamw2.pbl ‘Window library for Power

— w_n_up

—E  w_nested_ancestor

— B4 w_nested_frame

—HE w_newspaper_slide_columns
—HE & w_notepad

— FE & w_notepad_coiors
—E & w_notepad_find
Ed @ w_notepad_frame
—E & w_notepad_goto
— & w_notepad_replace

= w_pie_graph

The working copies are in WORKING.PBL.:

L #%8 working. pbl
E & w_notepad
F @ w_notepad_colors
& w_notepad_find
EH & w_notepad_frame
E & w_notepad_goto
F @ w_notepad_replace

Using the popup menu
You can also check out a Library entry by choosing Check Out from the
entry's popup menu.

Viewing the checked-out entries

You can display a list of the entries in the current application that are checked
out.

<+ To display the checked-out entries:

1  Click the Check Status button in the PainterBar.
or
Select Source>View Check Out Status from the menu bar.

The View Entries Check Out Status dialog box displays showing the
name of each entry in the current application that has been checked out
and the name of the library it is checked out to.
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2 Select the Show All Users checkbox to display all the entries that are
checked out from the current application.

2] d_richtext

@ User ID: kotwal

& Checked Out From: d:'pblsipbtest.pbl

Ca Checked Out To:  d:\pbls\datawindow. pbl
d_test1

@ User ID: kotwal

& Checked Out From: d:pbls\pbtest. pbl

& Checked Out To: d:\pbls\datawindow. pbl
m_genapp_frame

| UserID: kotwal

(Optional) Click Print to print the list of checked-out entries.

4 Click Close.

The View Entries Check Out Status dialog box closes and the Library

painter workspace displays.

Checking entries back in

When you finish working with an entry that you checked out, you check the

entry back in.

Checking in the Application object

Always check in the Application object by itself; PowerBuilder performs
unique tasks when you check in the Application object.

FOR INFO See "Working with the Application object" on page 90.
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.
0.0

To check in entries:

N =

Select the entries (the working copies) you want to check in.

Click the Check In button in the PainterBar.
or
Select Source>Check In from the menu bar.

PowerBuilder replaces the entries in the original library with the
working copies, deletes the working copies, then displays the Library
painter workspace.

If you selected an entry that another user has checked out,
PowerBuilder displays a message box and asks if you want to continue.
Click Yes to process any remaining entries.

Using the popup menu
You can also check in a Library entry by choosing Check In from the
entry's popup menu.

Clearing the check-out status of entries

2
0'0

Sometimes you will want to remove (clear) the check-out status of an entry
without checking the entry back in. Perhaps you have decided not to update the
object.

To clear the check-out status of entries:

1
2

Select the entries whose check-out status you want to clear.
Select Source>Clear Check Out Status from the menu bar.

A message box asks whether you want to clear the check-out status of
the entry.

Click Yes to clear the status.
You are asked whether you want to delete the working copy.

Click Yes to delete the working copy. Click No to retain it.
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Working with the Application object

PowerBuilder manages various background tasks when you check out or check
in the Application object.

Checking out an Application object

What happens

90

K/
*

When you check out the Application object, make the checked-out application
your current application to take advantage of PowerBuilder managing the
background tasks involved. If you keep the public library application as the
current application, you must perform those tasks yourself.

Check out only the Application object
Whenever you check out the current Application object, check it out by
itself.

To check out the Application object:
1 In the Library painter, select the current Application object.

2 Select Source>Check Out from the menu bar.
or

Click the Check Out button on the PainterBar.

3 Select the work library in the Check Out Library Entries dialog box and
click Open.

4  (Optional) Enter comments in the Check Out Comment dialog box.
5  Click Yes to make the checked-out application your current application.

FOR INFO  For how to modify the Application object, see "Modifying an
Application object" next.

When you check out the Application object and make that the current
application, PowerBuilder:

¢ Modifies the library path property of the Application object in your
work library to include all of the libraries in the library path property of
the Application object in the public library

¢ Associates with the Application object in your work library (now the
current application) the configuration file generated for the Application
object in the public library

¢ Maintains the connection to your version control system
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Modifying an Application object
Once the current Application object is in your work library, you can modify it
as you would any other PowerBuilder object.

7

*» To modify an Application object:

¢ In the Library painter, double-click the Application object in your work
library to open it.

Checking in an Application object

When you check in the Application object to the public library, PowerBuilder
performs tasks similar to those it handled when you checked out the
Application object.

Check in only the Application object
Whenever you check in the current Application object, check it in by itself.

% To check in an Application object:
1 Close the Application painter.

2 In the Library painter, select the Application object in your work
library.

3 Select Source>Check In from the menu bar.
or
Click the Check In button on the PainterBar.

4  Specify your comments and preferences in the Check In Library Entries
dialog box and click OK.

5  Click OK to continue.

What happens When you check in the Application object to the public library, PowerBuilder:
¢ Makes the application in the public library the current application

¢ Maintains the connection with your version control system
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Optimizing libraries

You should optimize your libraries regularly. Optimizing removes gaps in
libraries and defragments the storage of objects, thus improving performance.

Optimizing only affects layout on disk; it doesn't affect the contents of the
objects. Objects are not recompiled when you optimize a library.

Once a week
For the best performance, you should optimize libraries you are actively
working on about once a week.

K/

<+ To optimize a library:

Choose the library you want to optimize.

N =

Select Library>Optimize from the menu bar.
or
Select Optimize from the library's popup menu.

PowerBuilder reorganizes the library structure to optimize object and
data storage and index locations. Note that PowerBuilder does not
change the modification date for the library entries. PowerBuilder
saves the unoptimized version as a backup file in the same directory.

If you do not want a backup file

If you do not want to save a backup copy of the library, clear the Save
Optimized backups checkbox in the Library painter's Options tab
dialog. If you clear this option, the new setting will remain in effect
until you change it.
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Regenerating library entries

Occasionally you may need to update library entries. For example:

Regenerating
descendants

72
0.0

7
0.0

L4

When you modify an ancestor object, you can regenerate descendants
so they pick up the revisions to their ancestor.

When you make extensive changes to an application, you can rebuild
entire libraries so objects are regenerated sequentially based on
interdependence.

When you upgrade to a new version of PowerBuilder, you need to
migrate your applications.

When you regenerate an entry, PowerBuilder recompiles the source form
stored in the library and replaces the existing compiled form with the
recompiled form.

To regenerate library entries:

1
2

Select the entries you want to regenerate.

Click the Regen button.
or
Select Entry>Regenerate from the menu bar.

PowerBuilder uses the source to regenerate the library entry and
replaces the current compiled object with the regenerated object. The
compilation date and size are updated.

You can use the Browser to easily regenerate all descendants of a changed
ancestor object.

To regenerate descendants:

1

Click the Browser button in the PowerPanel.
The Browser displays.
Select the tab for the object type you want to regenerate.

For example, if you want to regenerate all descendants of window
w_frame, click the Window tab.
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3 Select the ancestor object and choose Show Hierarchy from its popup
menu.

The Regenerate button displays on the popup menu.

E2 w_about &= Properties

2 w_deleteme Events

Functions

ﬁo_j Estemal Functions

Instance Variables
(58 Shared Variables
(BB Stuctures

4 Click the Regenerate button.
PowerBuilder regenerates all descendants of the selected ancestor.

FOR INFO For more about the Browser, see "Browsing the class hierarchy"
on page 81.

Regenerate limitations

If you regenerate a group of objects, PowerBuilder will regenerate them in
the order they appear in the library, which may cause an error if an object is
generated before its ancestor. For this reason, you should use Rebuild to
update more than one object at a time.

Rebuilding libraries

94

When you make modifications to an application and need to update one or
more libraries, you should use the Rebuild option to update all the library
objects in the correct sequence.

There are two methods to use when you rebuild an application:

¢ Incremental rebuild Updates all the objects and libraries referenced
by any objects that have been changed since the last time you built the
application

¢ Full rebuild Updates all the objects and libraries in your application
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o,

** To rebuild an application:
1 Select the libraries you want to rebuild.

2 Depending on your needs, choose either Design>Incremental Rebuild
or Design>Full Rebuild from the menu bar.

Migrating libraries
When you upgrade to a new version of PowerBuilder, your existing
applications need to be migrated to the new version.

K/

% To migrate an application:
1 Double-click the application you want to migrate.

The Migrate Application dialog box displays.

D:\morepbls\profiler\profile. pbl,

2 Select OK.

PowerBuilder migrates all objects and libraries in the application's path
to the current version.
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Exporting and importing entries

You can export object definitions to ASCII text files. The text files contain all
the information that defines the objects. The files are virtually identical
syntactically to the source forms that are stored in libraries for all objects.

You may want to export object definitions in the following situations:
¢ You want to store the objects as text files.

¢ You want to move objects to another computer as text files.

Caution

The primary use of the Export feature is to export source code, not to
modify the source. Modifying source in an ASCII text file is not
recommended.

Later on you can import the files back into PowerBuilder for storage in a
library.

.
0.0

To export entries to text files:

1  Select the Library entries you want to export.
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2 Click the Export button.
or

Select Entry>Export from the menu bar.

The Export Library Entry dialog box displays showing the name of the
first entry selected for export in the File Name box and the name of the
current directory. The current directory is the directory containing the
last library you used.

brary Enl

PowerBuilder appends the file extension SRx, where x represents the
object type.

3 Specify the filename and directory for the export file. Do not change
the file extension from the one that PowerBuilder appended.

4  Click OK.

PowerBuilder converts the entry to ASCII file format, stores it with the
specified name, then displays the next entry you selected for export.

If a file already exists with the same name, PowerBuilder displays a
message asking whether you want to replace the file. If you say no, you
can change the name of the file and then export it, skip the file, or
cancel the export of the current file and any selected files that have not
been exported.

5 Repeat steps 3 and 4 until you have processed all the selected entries.

You can't see export files in the Library painter
Since export files are ASCII text files, the Library painter does not show
them; it shows only libraries and directories.
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< To import text files to library entries:

1

4

98

Click the Import button.
or
Select Entry>Import from the menu bar.

The Select Import Files dialog box displays showing the current
directory and a list of files with the extension SR* in that directory.
The current directory is the directory containing the PowerBuilder
library you used last.

; Select Import Files
R

g!] d_class_view_report.srd ;.f_] str_func_detail.srs
d_func_view_report.srd f:ﬂ w_profile_class.siw
: lglj d_trace_view_repoit.srd g w_profile_routine.srw
2| m_trace.srm :% w_profile_trace.srw
{g] n_profilefuncs. sru

i) str_func_class.srs

Select the files you want to import. Use SHIFT+click or CTRL+click to
select multiple files.

Click Open.

The Import File Into Library Entry dialog box displays listing the
libraries in the application's library search path.

it File Into Library Entry

Select the library you want to import the text files to.
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Click OK.

PowerBuilder converts the specified text files to PowerBuilder format,
regenerates (recompiles) the objects, stores the entries in the specified
library, and updates the entries' timestamps.

If a library entry with the same name already exists, PowerBuilder
replaces it with the imported entry.

Caution

When you import an entry with the same name as an existing entry, the
old entry is deleted before the import takes place. If an import fails, the
old object will already be deleted.
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Creating runtime libraries

If you want your distributed application to use dynamic runtime libraries, you
can create them in the Library painter.

FOR INFO For information about using runtime libraries, see Chapter 26,
"Creating an Executable". That chapter also describes the Project painter,

which you can use to automatically create dynamic runtime libraries.

% To create a runtime library:

Select the library you want to use to build a runtime library.

[\S

Select Library>Build Runtime Library from the menu bar.
or
Select Build Runtime Library from the library's popup menu.

The Build Runtime Library dialog box displays listing the name of the
selected library.

3 If any of the objects in the source library use resources, specify a
PowerBuilder resource file in the Resource File Name box (see
"Including additional resources" next).

4 If you want to build a library for deployment on a 16-bit platform,
select a format from the Executable Format drop down listbox.

Managing mixed environments

If you have both 16-bit and 32-bit versions of a project, you should be
aware that PowerBuilder doesn't recognize when the executable format
has been changed. It will overwrite the previous build. Be sure to
specify a full build whenever you switch between 16-bit and 32-bit
executable formats.
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5  Select other options as appropriate.

FOR INFO For more information about build options, see "Project
painter options" on page 878.

6  Click OK.

PowerBuilder closes the dialog box and creates a runtime library with
the same name as the selected library. If you used the machine code
compile option, the runtime library file extension is .dll on Windows
and UNIX. On the Macintosh, the letters lib are appended directly to
the library name with no period. If you did not select machine code, the
file extension is .pbd on all platforms.

Including additional resources

When building a runtime library, PowerBuilder does not inspect the objects; it
simply removes the source form of the objects. Therefore, if any of the objects
in the library use resources (pictures, icons, and pointers)—either specified in
a painter or assigned dynamically in a script—and you don't want to provide
these resources separately, you must list the resources in a PowerBuilder
resource file (PBR file). Doing so enables PowerBuilder to include the
resources in the runtime library when it builds it.

FOR INFO For more on resource files, see "Using PowerBuilder resource
files" on page 892.

After you have defined the resource file, specify it in the Resource File Name
box to include the named resources in the runtime library.
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Creating reports on library contents

You can generate three types of reports from the Library painter:

*

The search results report

¢ Library entry reports

*

The library directory report

The search results report contains the matching-entries information that
PowerBuilder displays after it completes a search, described in "Searching
library entries" on page 78. The other two types of reports are described in this
section.

Creating library entry reports

102

Library reports provide information about selected entries in the current
application. You can use these reports to get printed documentation about the
objects you have created in your application.

0

1
2

** To create library entry reports:

Select the library entries you want information about.
Select Entry>Print from the menu bar.

The Print Options dialog box displays.

Print Options

If you have selected the Application object or one or more menus,
windows, or user objects to report on, select the information you want
printed for each of these object types.

For example, if you want all properties for selected windows to appear
in the report, make sure the Properties box is checked in the
Window/User Object group box.
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The settings are saved
PowerBuilder records these settings in the Library section of the
PowerBuilder initialization file.

4  Click OK.

PowerBuilder generates the selected reports and sends them to the
printer specified in Printer Setup in the File menu.

Creating the library directory report

The library directory report lists all entries in a selected library showing the
following information for all objects in the library, ordered by object type:

Name of object
Modification date and time

Size (of compiled object)

* & & o

Comments

®

% To create the library directory report:
1 Select the library you want the report for.
2 Select Library>Print Directory from the menu bar.

PowerBuilder sends the library directory report to the printer specified
under File>Printer Setup in the menu bar.
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PART 2 Coding Fundamentals

This part describes how to code your application. It
covers the basics of the PowerScript language, how to
use the PowerScript painter, and how to create
functions and structures to make your code more
powerful and easier to maintain.






CHAPTER 4

About this chapter

Contents

For more information

Writing Scripts

PowerBuilder applications are event driven. You specify the processing
that takes place when an event occurs by writing a script. This chapter
describes how to use the PowerScript painter to write scripts using the

PowerScript language.

Topic Page
Opening the PowerScript painter 108
Working in the PowerScript painter 110

For complete information about the PowerScript language, see the

PowerScript Reference.
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Opening the PowerScript painter

You can open the PowerScript painter (also called the Script painter) from the
Application, Window, Menu, or User Object painter (because you can attach
scripts only to Application objects, windows and their controls, menus, and
user objects).

K/
*

To open the PowerScript painter:
1 Select the object or control you want to write a script for.

To write a script for a window (as opposed to a control in the window),
make sure no control is selected.

2 Do one of the following:

¢ Display the popup menu for the object or control, then choose
Script from the menu.

¢ Click the Script button in the PainterBar:
This button | Shows

D The selected object or control has no scripts

The selected object or control has at least one script

What happens The PowerScript painter opens in a separate window.
When you open the PowerScript painter, the following information displays:

Item What/Where it displays

Name of the current event In the painter's title bar.

If multiple events can occur in the object you are
working with, the current event is the last event
for which a script was displayed. If there is no
script, the current event is an event that typically
has a script

Name of the current object In the painter's title bar
or control

Select Event dropdown Lists events for the current object or control
listbox

Paste Argument dropdown Lists arguments for the current event
listbox
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Item

What/Where it displays

Paste Object dropdown
listbox

Lists objects and controls whose names you can
paste into the script

Paste Global dropdown
listbox

Lists global variables you can use in the script

Paste Instance dropdown
listbox

Lists instance variables you can use in the script

FOR INFO For more about instance variables, see
the PowerScript Reference

Script for the current event

Changing the current event

If there is no script, the workspace is blank

If the object or control has multiple events, you can change the current event
by selecting an event from the list in the Select Event dropdown listbox.

Seeing which events have scripts

The Select Event dropdown listbox in the PowerScript painter indicates which
events have scripts, as follows:

If there is a script

This happens

For the object or control you are A script icon displays next to the event

working with

In an ancestor object or control only The script icon displays in color

In an ancestor as well as in the object The script icon displays half in color

or control you are working with
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Working in the PowerScript painter

You write scripts in the PowerScript painter. It provides all the features needed
for writing and modifying scripts. For example, you can cut, copy, and paste
text, as well as search for and replace text.

The PowerScript painter automatically:

¢ Color-codes scripts to identify data types, system-level functions, flow-
of-control statements, comments, and literals

¢ Indents the script based on flow-of-control statements

The painter also provides many features that make it easy to use the
PowerScript language, such as facilities for pasting information into scripts.

Modifying Painter properties

.

*% To specify painter properties:
1  Select Design>Options to display the property sheet.
2 Choose the tab appropriate to the property you want to specify:
To specify Choose this tab

The default font for static text as it appears in windows, | General
user objects, and DataWindow objects

Font family, size, and color for the PowerScript painter | Font

Text and background coloring for PowerScript syntax Coloring
elements

Dropdown lists you want to include on the PowerScript | Dropdowns
painter

These properties are discussed below.

Modifying painter properties

Some properties you specify in the PowerScript painter also affect the
Function painter, File editor, Data Manipulation painter, Select painter, and
Debug window.
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Specifying general
script properties

The General page of the PowerScript painter property sheet allows you to
specify:

¢ Tab size
¢ Whether you want to enable automatic indenting of scripts
¢ Whether you want to allow dashes in identifiers

In addition, you can specify whether you want the compiler to display:

¢ Compiler warnings
¢ Database warnings
¢ Informational messages
¢ Obsolete messages
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Specifying a font for
your script

Customizing colors in
your script

112

The PowerScript painter Font property page allows you to specify the font,
size, style, color, and special effects you want to use when you write scripts.

H Courier New
"} Desdemona
s

I/ ndText

Use the Coloring page of the PowerScript painter property sheet to enable
syntax coloring in your scripts.

Sample Text

When you enable syntax coloring, the PowerScript editor color-codes scripts
to identify data types, system-level functions, flow-of-control statements,
comments, and literals.

You can customize colors by setting the text and background color of the script
elements listed in the listbox.
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Customizing the Use the PowerScript painter property sheet Dropdowns page to specify the
PowerScript painter paste boxes you want to include in the PowerScript painter.

Sel hi
Paste Argument
Paste Object
Paste Global
Paste Instance

Using the PainterBar and menu bar

You can perform standard editing tasks in the PowerScript painter. Like the
other painters, the PowerScript painter has a PainterBar that provides a shortcut
for performing frequently used activities. There is also a corresponding menu
item (and often a shortcut key) for each activity:

Menu item Shortcut key | Activity

Edit>Undo CTRL+Z Undoes the most recent edit

Edit>Cut CTRL+X Cuts selected text to the
clipboard

Edit>Copy CTRLA4C Copies selected text to the
clipboard

Edit>Paste CTRL+V Pastes the contents of the

clipboard at the current cursor
location; replaces any selected
text

Edit>Paste Function

Pastes a function statement at
the current cursor location

Edit>Paste SQL

Pastes a SQL statement at the
current cursor location
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Menu item

Shortcut key

Activity

Edit>Paste Statement

Pastes a PowerScript statement
at the current cursor location

Edit>Clear

DELETE

Deletes selected text; does not
place the text in the clipboard

Edit>Select All

CTRL+A

Selects all text in the workspace

Edit>Comment Selection

Comments out the current line
or all lines containing selected
text by inserting two slashes
before the first character in each
line

Edit>Uncomment Selection

Uncomments the current line or
all lines containing selected text
by removing the two slashes
before the first character in each
line

Search>Find

CTRLA+F

Specifies a string for which you
want to search the script

Search>Find Next

CTRL+G

Finds the next occurrence of the
specified search string

Search>Replace

CTRL+H

Replaces the specified search
string

Search>Go to Line

CTRL+SHIFT+G

Goes to a specific line number

Design>Compile Script

CTRL+L

Compiles the script

Design>Select Object

Selects an object to paste at the
cursor location

Design>Browse Object

Opens the Browser

File>Return

CTRL+SHIFT+T

Returns to the painter from
which you opened the
PowerScript painter

On Macintosh On Macintosh systems, use COMMAND instead of CTRL.

On UNIX On UNIX systems, you can also use the middle mouse button and
dedicated editing keys on your keyboard for copying and pasting text if
your window manager supports them.
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Getting context-sensitive Help

K2
0’0

In addition to accessing Help through the Help menu and F1 key, you can use
context-sensitive Help in the PowerScript painter to display Help for reserved
words and built-in functions.

To use context-sensitive Help:

1 Place the insertion point within a reserved word (such as DO or
CREATE) or built-in function (such as Open or Retrieve).

2 Press SHIFT+F1.

The Help window displays information about the reserved word or
function.

Copying Help text

You can copy text from the Help window into the PowerScript painter. This
is an easy way to get information about arguments required by the built-in
functions.

Printing your script

You can print the current script on the default printer by selecting File>Print
from the menu bar.

To change the printer or its settings, select File>Printer Setup from the menu
bar before printing.

Pasting information

Scripts frequently reference objects and controls or the names of variables and
built-in functions. To quickly access these entities, you can paste information
directly into scripts:

To paste Use

Objects, controls, arguments, and Paste listboxes above workspace
global and instance variables

Properties, data types, functions, Browser
structures, variables, and objects

Contents of clipboard Edit>Paste
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To paste Use
PowerScript statements Paste Statement button
or

Edit>Paste Statement

SQL statements Paste SQL button
or
Edit>Paste SQL

Built-in, user-defined, and external Paste Function button
functions or
Edit>Paste Function

Contents of text files File>Import

Undoing a paste
If you paste information into your script by mistake, immediately click the
Undo button or select Edit>Undo from the menu bar.

These techniques are explained in the sections that follow.

Using the Paste listboxes

You can use the Paste listboxes just above the painter workspace to paste the
name of an object, control, or variable that is currently available. The listboxes
are accessible using the mouse or the keyboard.

% To use the Paste listboxes using the mouse:

1 Move the cursor where you want to paste the object, control, or
variable.

2 Click the Paste listbox for the type of information you want to paste.
(See below for information about each of the listboxes.)

A list of available objects and controls or variables displays.
3 Click the entity you want to paste.

PowerBuilder closes the list and pastes the selected object, control, or
variable at the insertion point in the script.
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The Paste Object
listbox

The Paste
Arguments listbox

The Paste Global
listbox

The Paste Instance
listbox

To use the Paste listboxes using the keyboard:

1 Move the cursor where you want to paste the object, control, or
variable.

2 Press CTRL+number to drop down a listbox (CTRL+1 drops down the
Select Event listbox, CTRL+2 drops down the Paste Object listbox, and
SO on).

Use the arrow keys to select the entity.

~

Press ENTER.

If you accessed the Select Event listbox, you go to the script for the
selected event. If you accessed one of the paste listboxes, the selected
entity is pasted in the script.

What appears in the Paste Object listbox depends on which painter you opened
the PowerScript painter from:

Painter What displays

Application All windows defined for the application (all windows in the
library search path for the Application object)

Window All controls contained in the window, along with the name of
the window itself

Menu All Menultems in the current menu

User Object All controls and user objects contained in the user object, along
with the name of the user object itself

For example, if you are writing a script for a window control, you can use the
Paste Object listbox to paste the name of another control in the current window.

The Paste Arguments listbox displays all arguments defined for the selected
event. (To define additional arguments for a user-defined event, select
Declare>User Events from the menu bar.)

The Paste Global listbox displays all global variables defined for the
application. (To define additional global variables, select Declare>Global
Variables from the menu bar.)

The Paste Instance listbox displays all instance variables defined for the
corresponding Application object, window, menu, or user object, or one of its
ancestors. (To define instance variables, select Declare>Instance Variables
from the menu bar.)

Shared variables are not displayed in the listbox. To access them, choose
Declare>Shared Variables from the menu bar or use the Browser.
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Using the Browser

You can use the Browser to paste the name of any property, data type, function,
structure, variable, or object in the application.

The Browser has two panes:

@2 Properties
Events
Functions

@5 Extenal Functions

{58 Instance Variables
Shared Variables
(5% Stuctures

The left pane displays one type of object, such as window or menu. The right
pane displays the properties, events, functions, external functions, instance
variables, shared variables, and structures associated with the object.

Getting context-sensitive Help in the Browser
To get context-sensitive Help for an object, control, or function, select Help
from its popup menu.

% To use the Browser to paste information into the PowerScript painter:

1 Move the cursor where you want to paste the information. Select any
text you want replaced by the pasting.

2 Click the Browse Objects button located in the PainterBar.
or
Select Design>Browse Object.

The Browser opens showing the object that is currently open in the
PowerScript painter. If you want to paste information about another
object, select the appropriate tab and then select the object in the left
pane.

3 Select the category of information you want to display by expanding
the appropriate folder in the right pane.
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4  Select the information and click Copy.

PowerBuilder closes the Browser and displays the information at the
insertion point in the script, replacing any selected text.

FOR INFO  For information about using the Browser to paste OLE object
information into a script, see Application Techniques.

Opening the Browser for pasting

There is a Browser button in the PowerBar and a Browse Objects button in
the PainterBar. Both buttons display the Browser. However, the Browse
Objects button in the PainterBar makes it easier for you to paste objects into
your script because it displays information for the object you’re working on.

Pasting statements
You can paste a template for the following PowerScript statements:
¢ [IF..THEN
¢ DO..LOOP
¢ FOR..NEXT
¢ CHOOSE CASE

When you paste these statements into a script, prototype values display in the
syntax to indicate conditions or actions.

.

<+ To paste a PowerScript statement into the script:
1 Move the cursor where you want to paste the function.

2 Select the Paste Statement button from the PainterBar.
or
Select Edit>Paste Statement from the menu bar.

The Paste Statement dialog box displays.

| Paste Statement
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3 Select the statement you want to paste into the script and click OK.
The statement prototype displays at the insertion point in the script.

4 Replace the prototype values with the conditions you want to test and
the actions you want to take based on the test results.

FOR INFO For more about PowerScript statements, see the PowerScript
Reference.

Pasting SQL
You can paste a SQL statement into your script instead of typing the statement.

7

% To paste a SQL statement:

1 Place the insertion point where you want the SQL statement in the
script.

2 Click the Paste SQL button in the PainterBar.
or
Press CTRL+Q.
or
Select Edit>Paste SQL from the menu bar.

The SQL Statement Type dialog box displays.

3 Select the type of statement you want to insert by double-clicking the
appropriate button.

The appropriate dialog box displays so you can paint the SQL
statement.
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4 Paint the statement, then return to the PowerScript painter.
The statement displays at the insertion point in the workspace.

FOR INFO For more about embedding SQL in scripts, see the PowerScript
Reference.

Pasting functions

You can paste any function into a script.

®,

+» To paste a function into a script:

1  Click the Paste Function button in the PainterBar.
or

Select Edit>Paste Function from the menu bar.

The Paste Function dialog box displays.

2 Choose the type of function you want to paste: built-in, user-defined, or
external.

3 Double-click the function you want.

PowerBuilder pastes the function into the script and places the cursor
within the parentheses for you to define any needed arguments.

For more information For more about pasting user-defined functions, see "Pasting user-defined
functions" on page 146.

For more about external and built-in functions, see Application Techniques.
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Pasting contents of files

Importing from a file

Exporting a script to
a file

122
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You can import the contents of an external text file into the PowerScript painter
or export the contents of the script to a text file.

If you have code that is common across different scripts, you can keep that
code in a text file, then read it into new scripts you write.

To import the contents of a file into the PowerScript painter:

1
2

Place the insertion point where you want the file contents pasted.
Select File>Import from the menu bar.

The File Import dialog box displays listing all files with the extension
SCR.

Choose the file containing the code you want. You can change the type
of files displayed by changing the file specification in the File Name
box.

PowerBuilder copies the file into the PowerScript painter at the
insertion point.

You might want to save all or part of a script to an external text file for use later.
This is useful when you:

¢ Want to use the code in another script

*

Are about to make a major change to a script and want to make sure
you have a backup file with the current script in case you need it

To save the contents of a script to a text file:

1

If you want to save the entire script, make sure no text is selected. If
you want to save only part of the script, select the part you want to save.

Select File>Export from the menu bar.
The File Export dialog box displays.
Name the file and click OK.

The default file extension is SCR.
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Compiling the script

Before you can execute a script, you must compile it. There are two ways to do
it.

2

** To compile the script and remain in the PowerScript painter:

¢ Click the Compile button.
or
Select Design>Compile Script from the menu bar.
or
Press CTRL+L.

PowerBuilder compiles the script and reports any problems it finds, as
described in "Handling problems" next.

% To compile the script and immediately return to the painter you came
from:

¢ Click the Return button, as described in "Leaving the PowerScript
painter" on page 127.
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Handling problems

Understanding errors

Understanding
warnings

124

If problems occur when a script is compiled, PowerBuilder displays messages
in a window below the script.

fSelect Event §{ Paste Argument Paste Object Paste Instance

connect asing sqlca;

// Get name of DW object from du_list Report_Name column...
1s_reprot = du_list.Object.report_name[li_row]

// ASsign DW object name to the DW control. If can't set trans object,
/7 then the DW object name is bad...
dw_reports.Datalbject = 1s_report
If dw_reports.SetTransObject(SQLCA) <> 1 THEN
Beep(1)
MessageBox("Programmer Error',"Report name not found”, Stopsign?)
KRETURN
ELSE
dw_reports.Retrieve()
cbx_preview.Enabled = TRUE
ENDIF

: Error €C0081: Duplicate variable: 1i_row
(8604): Information CO146: The identifier ‘error' conflicts with an existir
(8014) : Obsolete C8158: Function ‘GetMessageText' is now obsolete and wi
: Warning CO814: Undefined variable: 1s_reprot
: Warning CO014: Undefined variable: endif

Invalid statement
Syntax error

There 